WordPress.org

Support

Support » Plugins and Hacks » Network Publisher » [Resolved] Network Publisher Conflict with WP eCommerce

[Resolved] Network Publisher Conflict with WP eCommerce

  • richstrauss

    @richstrauss

    Hello,

    I seem to have found a conflict between Network Publisher and WP e-Commerce, and seemingly after upgrading to Network Publisher 3.5.0.

    In my WP e-Commerce product pages, when clicking on “Add to Cart” the ajax based “Updating” wheel keeps spinning and hangs. The item does get added to the cart, but without the confirmation message coming to a conclusion. The item can be seen in the cart only after clicking another link, or refreshing the page.

    I am by no means an expert, and mainly use Firefox, I am not sure how to use FireBug for debugging, but from what I have tried, all the scripts seem to pass the tests.

    In IE 8 however, when using the Web Developer JavaScript Debugging tool when adding an item to the cart, it first jumps to line 119 of plugins/wp-e-commerce/js/wp-e-commerce.js

    Line 119 = eval(returned_data);
    Message: Expected ‘;’ wp-e-commerce.js?ver=3.7.58, line 119 character 5

    I have de-activated my plugins one by one, and found Network Publisher to be the culprit. When deactivated, “Add to Cart” works fine.

    I have spent a lot of time trying to get everything right on my site, and everything worked OK till now…

    I am running WordPress 3.0.2., Network Publisher 3.5.0 and WP e-Commerce 3.7.7 without the Gold Cart.

    I have only one product in my shop for now, till all runs smoothly, you can see it here: http://www.richardtstrauss.com/fine-art-photography-prints/nature/

    http://wordpress.org/extend/plugins/network-publisher/
    http://wordpress.org/extend/plugins/wp-e-commerce/

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author vivekpuri

    @vivekpuri

    I will look into it and get a fix in the next release that should come soon.

    Awesome 🙂

    Thank vivekpuri!!!

    Awesome 🙂

    Thank vivekpuri!!!

    richstrauss

    @richstrauss

    Thank you very much vivekpuri! Sorry the delayed reply, I’ve been away from internet a few days.

    Any idea when the new release will be available with this fix? Thanks again!

    Plugin Author vivekpuri

    @vivekpuri

    @richstrauss Let me know if i can test something on your site for this issue. You can open ticket at – http://support.linksalpha.com/home with your site details and we can continue from there.

    @vivekpuri – Thank you very much! I have just opened a ticket.

    Vivekpuri,

    I actually have this exact same issue however it seems to be conflicting with something else. What was it that you changed in your plugin to resolve this issue?

    Feel free to contact me on AIM: gamegenius86 if you’d like.

    Michael

    I just went through and deactived every plugin except the WP-E-Commerce and the when clicking on “Add to Cart” the “Updating” wheel keeps spinning and hangs.

    Hopefully this information helps. Anything you guys and provide back to me on how to resolve this issue as well would be greatly appreciated.

    When the add to cart is clicked it fires off an Ajax post. The response to that post should be some Javascript that gets executed, which will get rid of the spinner and show a message that the item has been successfully added to the cart.

    On the site you posted the contents of the AJAX response appear to be prefixed with a “-1”

    If you use firebug, on the net panel, open up the response tab and you’ll see something like this:

    -1if(jQuery('#fancy_notification_content')) {
    instead of
    if(jQuery('#fancy_notification_content')) {

    I’m not familiar enough with “Network Publisher” to say what might be causing this – possibly it’s also trying to respond to the Ajax request, and outputting an error code because it can’t find information it’s looking for?

    Looking briefly at the Network publisher code it appears that networkpub_remove is fired on init(), and doesn’t look for a specific action – just assumes that if ‘key’ is included in the POST data then it should do something. My money is on this being the problem (Since your site is POSTing a variable called “key” with a value of -1 …)

    Hope that helps …

    I hope that helped out [richstrauss]. However it seems like this could be an issue with WP-E-Commerce not with the other plugin. ButI could be wrong on that.

    Basically we are having the exact same issue that when you press the Add to Cart icon in either the single product or product list, the “loading..” will hang (freezes there and wont go to the “you added xxx to cart: continue shopping or go to checkout” nor does it add it to the cart widget). The request was processed correctly as if you refresh page it will appear in your cart widget. This issue also ONLY happens in Internet Explorer for me, works fine in Chrome.

    Here is a link to one of the store pages:
    http://at-riskyouth.org/products/estore/printed/teens/anger-management/

    Plugin Author vivekpuri

    @vivekpuri

    i will try looking into this issue today…

    @michael86 – your issue is most probably caused by the fact that you’re loading two copies of jQuery – one from your theme (Which is presumably hardcoding it in instead of using WordPress’ enqueue_script mechanism), and the one from WP e-Commerce which enqueue’s it properly.

    If you remove the rogue jQuery it’ll probably work fine. Definitely a different issue to richstrauss’

    Plugin Author vivekpuri

    @vivekpuri

    This issue is now fixed. Version 4.0 has the fix. For those already on version 4.0, please download the plugin again and replace files.

    Thanks to @leewillis77 for the tip.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] Network Publisher Conflict with WP eCommerce’ is closed to new replies.
Skip to toolbar