Support » Networking WordPress » Network option issues

  • Resolved Zarevac


    Previously I was using the mu version of WP for my sites. This all worked fine and peachy. I redid my site and basically created a new install of the latest version of WP. I went to the Network guide page and followed the steps and started running into problems.

    The first problem was that I couldn’t get permalinks to work. When I went into the admin section and clicked on the permalinks page it was blank with the exception of the menu bar. (Which is weird because permalinks with e.g. Drupal just work fine). After some searching I found a solution and got it working namely:

    The second problem seemed to be similar. After editing the wp-config.php file as directed the option of Network appears in the menu bar. But when I click on it I get a blank page. Trying all kind of things, even contacting my host I got the message back that it was most likely related to Cpanel and VHOST’s and I was given the advice to revert back to the latest version of MU.

    Now my host gives me a lot of space and room to work in, I have 512MB of RAM to my disposal and they even turned mod_sec of for me to see if that was the issue. The question now is, if there is a way for me to fix this?

    I am willing to try everything (except running naked through the park) and would appreciate some guidance.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    When you redid your site, you said you “basically created a new install of the latest version of WP”.

    Had you imported the old data?

    I ask this, because if so, there could be lingering things in there, where WordPress thinks it’s an upgraded MU install – in which case you don’t touch the Network setup.

    Anyone who has gone from WPMU to 3.0 and above without following the upgrading instructions has run into all sorts of problems.

    No I didn’t import the data as the site I want to use as a central only had a couple of pages. I also just used another domain and created a brand new clean install in the mean time but run into the same problem there. No error logs, even if I put Debug on true.

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    The error logs would be put out by your server, not WordPress.

    If it’s a brand new install, I’d be tempted to tear it down and start all over again.

    hand-holding version, with tips:

    I retried the install but keep running into the same problem.

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    Blank page = errors. Have you checked any php error logs?

    What host are you on?

    No errors in the log. Mod sec is off also.

    Host is Hostdime. My server info is:

    Operating system Linux
    Path to PERL /usr/bin/perl
    Server Name server
    Kernel version 2.6.18-194.11.4.el5
    cPanel Version 11.26.20
    Architecture x86_64
    MySQL version 5.0.91-community
    Path to sendmail /usr/sbin/sendmail
    Apache version 2.2.16
    PHP version 5.3.3
    cPanel Pro 1.0 (RC1)

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    Look at the source of the page, the Network menu setup page. Where is it dying? Find that, follow that error.

    OK for some strange reason something goes wrong with WP, Apache and loading/detecting Apache modules on my server. As I have a dedicated box with a lot of freedom I am not sure if this has to do with any of my settings or if this will appear with others. Either way this might help.

    I finally found something that helped me bypass the problem in \wp-includes\functions.php line: 3349 and change the following code:

    function apache_mod_loaded($mod, $default = false) {
    	global $is_apache;
    	if ( !$is_apache )
    		return false;
    	if ( function_exists('apache_get_modules') ) {
    		$mods = apache_get_modules();
    		if ( in_array($mod, $mods) )
    			return true;
    	} elseif ( function_exists('phpinfo') ) {
    			$phpinfo = ob_get_clean();
    			if ( false !== strpos($phpinfo, $mod) )
    				return true;
    	return $default;


    function apache_mod_loaded() {
    	return true;

    After that I could access the page, configure the Network and save it. I now see Super Admin and all appears to be working fine.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Network option issues’ is closed to new replies.