Support » Plugin: WP Multi Network » Network Of Networks

  • Resolved nitiniyer

    (@nitiniyer)


    I’m trying to create a network of Networks using Sub-domains and Sub-directories. Installed a fresh copy of WP, enabled Multi sites, then added WP Multi Network plugin. Commented out the required line in Wp-config file. Created a new *.DOMAIN.COM record.
    Im able to create new networks. It works like a charm, but when I try to access wp-admin of the network, I get a 404 page and if I try to visit the network site, I get a CGI template error.
    I have confirmed that the sub-domain pointing is working properly as the name gets resolved to the server IP. I have been trying to figure out the issue but am unable. Please someone help me.

    https://wordpress.org/plugins/wp-multi-network/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Did you follow all of the installation suggestions in ?

    Yes all steps were followed. The problem was with the Virtual Host settings. We need to apply proper entries to the the httpd.conf file and it worked perfectly there after. Thank you.

    nitiniyer would you mind sharing your proper entries to the the httpd.conf file?

    I am trying to get it to work on localhost and get: This site can’t be reached when I go to the network, not sure if my mappings are right or need to edit the httpd.conf file to get it to work.

    Dennis

    Hi Dennis,
    Following was my original entry in the HTTPD.CONF file:
    <VirtualHost <SERVER_IP:80>
    ServerName <DOMAIN_NAME.COM>
    ServerAlias http://www.<DOMAIN_NAME.COM&gt;
    DocumentRoot /home/<PATH_TO_PUBLIC_HTML>
    ServerAdmin webmaster@<DOMAIN_NAME.COM>
    UseCanonicalName Off
    ……

    This I changed with the following:
    <VirtualHost <SERVER_IP:80>
    ServerName <DOMAIN_NAME.COM>
    ServerAlias http://www.<DOMAIN_NAME.COM&gt; *.<DOMAIN_NAME.COM>
    DocumentRoot /home/<PATH_TO_PUBLIC_HTML>
    ServerAdmin webmaster@<DOMAIN_NAME.COM>
    UseCanonicalName Off
    ……

    Once this change was done the setup was working like a harm 🙂

    Thanks @nitiniyer,

    I’ve tried every possible version of your code that I can think of, but it’s still not working

    In my host file, I’ve tried all of this settings and still not working!

    testcenter.com
    *.testcenter.com
    127.0.0.1 testcenter.localhost
    127.0.0.1 testcenter.com.localhost
    127.0.0.1 localhost.testcenter.com
    127.0.0.1 localhost.testcenter

    In Networks > Domain, I’ve tried the same setting as in host file, either I get this pages can’t be found, or I’m taken out of my local environment where it tries to connect to a live site.

    I think the bottleneck here is the domain.
    In Networks, how to you enter the Domain the way it works for you?

    Regards
    Dennis

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Network Of Networks’ is closed to new replies.