Support » Networking WordPress » network not showing up in tools

  • Resolved Babs

    (@turquoisefish)


    Hi,

    I’m at a loss; I’ve tried everything I can think of & still no “network” under tools. I was able to successfully create the A host in the DNS with the *. I followed the WordPress installation. Edited the wp-config.php file, even tried multiple things there. I removed WordPress & installed WordPress MU (don’t do this LOL), and resorted to downloading the 3.0 and manually installing. Previously, I had just upgraded to 3.0 but not from WordPress MU, just WordPress (finding there were 2 kinds took some time to figure out as well).

    I’m tired, so maybe not recalling what else I’ve done, but whatever logical step that should be done, I tried it. I’m using the default BuddyPress theme, and I have now upgraded the default theme. Still, nothing. Hmmm, I haven’t tried it without the BuddyPress theme though. I could not get BuddyPress to work right using another BuddyPress theme.

    Oh, I remember; I also have my blog in a subdirectory folder (meaning the WordPress files are not separate from the main index file and such but they are not in root). I read that may be a problem, so I backed up my root files, moved them and installed my WordPress there. Nothing (meaning my site worked as it did prior to moving to the root; still no network under tools).

    I disabled plugins and whatever else. Everything is the same. No network. 🙁 I’m hosting with godaddy (don’t judge lol).

    I’m looking to do subdirectories, multiple blogs.

Viewing 15 replies - 1 through 15 (of 19 total)
  • Roy

    (@gangleri)

    Did you see this?:
    http://codex.wordpress.org/Create_A_Network

    I’ve done a few networks now, all installed within minutes.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    I’m hosting with godaddy (don’t judge lol).

    goDaddy will not support the Network on their bottom-line shared hosting account.

    Babs

    (@turquoisefish)

    Yes, thank you, that would be where I started more than a week ago. That’s how I know I am supposed to see a “network” under tools, which I do not.

    I also spoke to GoDaddy re: do they support this per those aforementioned instructions, & GoDaddy emailed me there own help link, which is a condensed version of the WordPress one (without the A host and such). However, GoDaddy’s version said to place the multi user string in a location that was, in my opinion, very vague as to what they meant. So, I tried it in several logical areas.

    I would suspect that DNS/hosting aside, I still should be seeing this link under Tools, am I right? If I add that multi-user string to wp-config, that should show up in my admin panel. I have placed it according to the instructions in the Create_A_Network link along with all of the other things I wrote that I have already tried. Currently, we are back to where I started more than a week ago, just a lot of time lost. yea.

    Thank you for any assistance & advice.

    Babs

    (@turquoisefish)

    Andrea, do you know who will? Naturally, GoDaddy didn’t mention that (and I called them more than once).

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    have placed it according to the instructions in the Create_A_Network link along with all of the other things I wrote that I have already tried.

    Just for giggles:

    – you placed this line
    ‘define(‘WP_ALLOW_MULTISITE’, true);’

    somewhere in the middle of wp-config.php. Yes? Not at the beginning, not at the end. all on its own line.

    Babs

    (@turquoisefish)

    Specifically,

    I placed it between “defin (WPLANG) and before “that’s all…” in various places such as with a blank line between, without, etc. above “that’s all…” below “that’s all… and some other places nearby including at the end, but currently it’s before “that’s all” and after define:

    * Change this to localize WordPress. A corresponding MO file for the chosen
    * language must be installed to wp-content/languages. For example, install
    * de.mo to wp-content/languages and set WPLANG to ‘de’ to enable German
    * language support.
    */
    /* edited for reference only so it will post to support: define (‘WPLANG’, ”); */

    /* That’s all, stop editing! Happy blogging. */

    (This is copied from another site, as well, so it’s not the wp-config from that site; however, should be the same info if I recall correctly.)

    Babs

    (@turquoisefish)

    /* define (‘WPLANG”, “); */
    /* Currently, I have the text here without this written info: define(‘WP_ALLOW_MULTISITE’, true);
    */
    /* Would have left That’s all, stop editing! Happy blogging.” here */

    enjaytee

    (@enjaytee)

    This drove me mad and it was all down to the ‘hyphons’! around ‘WP_ALLOW_MULTISITE’ I copied it into the config from somewhere on the web into notepad.

    After pulling my hair out as to why the Networks hadn’t showed up I opened wp-config in notepadd++ and it showed me the errors (and I think I heard it snigger at me)

    I know I’m stupid but if it helps anyone else …..

    Now can I post this as Anonymous?

    Babs

    (@turquoisefish)

    hmmm, well, notepad++ is another issue. lol That is installed on my other (main desktop) computer & doesn’t work! I’ve just gone on without it. However, I have been editing text in Crimson. I do have dreamweaver, but am not editing text in that because I read that it can create errors.

    re: notepad++ issue, it doesn’t even open. However, the icon is changed recognizing it where notepad used to be and such. I just can’t get it to launch. Followed the directions precisely.

    I can’t see the hyphons being the problem, as I know I need them and don’t see anything wrong with them. I’ll go look again when I’m done with the jobs that actually pay me something. :sigh: 🙂 Thank you for the additional info.

    Babs

    (@turquoisefish)

    Ok, guess I missed my window to fix my error, I meant hyphens.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    He didn’t mean hyphens he meant the quotes. 🙂 On windows they are often converted to “smart quotes” and mess things up when copy-pasting.

    when in doubt, type it in directly.

    Babs

    (@turquoisefish)

    Ha! You two are wonderful! Thank you!!!! Problem fixed. Couse, now I see a lot of the same issue in support search, but I did not see any yesterday. You have to physically type in that string of info.

    enjaytee

    (@enjaytee)

    I did mean quotes! Where did I get hyphens from lol! I didn’t even spell it correctly.
    Crazy day yesterday sorry. Must have had a panic. I don’t comment alot.

    Glad you are up and running. Have fun

    spherical

    (@spherical)

    Not showing up in mine either. I started with WPMu 2.7 as my first choice when switching to WP. Upgraded from 2.9.2 to 3.0 and all of the “blogs” just showed up as “sites”. Domain mapping worked. There’s a “Super Admin” menu. There’s a “Domains” sub-menu. No “Network” menu anywhere, though. Seeing this thread, I decided to check on what someone else may have found. Interestingly enough, all of this worked without my having edited wp-config.php to add that line. Probably the fact that the database was already in the correct configuration.

    Ah-ha! “Okay, I’ll put that line in!” and .. nothing. No “Network” menu still.

    EDIT: Found it. the line:

    define(‘MULTISITE’, true);

    has to be in there for the “Network” menu to show. (No “WP_ALLOW_”)

    spherical

    (@spherical)

    BUT (edit capability timed-out before I could get back in to change it) Don’t put that line in. Once I logged out and back in again, I got a database connection error with it in there. So, it appears that once you set up Multisite (didn’t actually have to with mine ‘cuz I was WPMu going in) the Network menu no longer appears. It’d be great if this was shared somewhere in the docs. Did I miss it?

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘network not showing up in tools’ is closed to new replies.