WordPress MU Domain Mapping
[resolved] Network domain in image urls, how to change to mapped domain instead (3 posts)

  1. Keith Aldrich
    Posted 2 years ago #

    Is there a filter to use the mapped domain in image URLs rather than the network domain and sub-folder?

    The rewrite rules are working perfectly...

    So an image stored in the network domain http://bozemandigital.com/mt4x4/wp-content/uploads/sites/4/2011/09/mountaineers_top_truck_2011_053.jpg

    Can be accessed via the mapped domain http://mt4x4.com/wp-content/uploads/sites/4/2011/09/mountaineers_top_truck_2011_053.jpg

    The first (network domain URL) of the two examples is what is showing up in the admin media area as the image URL. I'd like it to show as the second (mapped domain URL).

    Also, when viewing page source, the first URL (network domain) shows up. I'd like the second (mapped domain) to be used.

    I'm hoping that someone can advise me how to set up a filter in functions.php to make this change...as it is a bit over my head.



  2. Keith Aldrich
    Posted 2 years ago #

    Here are a couple of screenshots to show what I'm talking about.

    This screenshot of the admin area, I'd like the "image URL" (highlited area on right) to use the mapped domain of mt4x4.com, not the network domain.


    On this screenshot, I'd like the page source to use the mapped domain, rather than the network domain.


  3. Keith Aldrich
    Posted 2 years ago #

    Okay, managed to solve this on my own.

    Just had to change the site url and home in site settings from networkdomain/subfolder to mappeddomain

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress MU Domain Mapping
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic