Support » Networking WordPress » Network dashboard gives error 500, though main site and its adminCP load file

  • Resolved iceq

    (@iceq)


    Hi. My network has been working fine. I did not make any change that could have caused this Dont know why it happened. I was inside the Network dashboard performing ordinary things. Suddenly while navigating inside, I got HTTP error 500 , internal server error , although the main site loads fine , and its dashboard as well.

    I renamed the hataccess file and then a new blank one was automatically created, I copied the contents of the old one into it, but that did not help. Its content is currently :

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    What could it be ?

Viewing 15 replies - 1 through 15 (of 42 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Check your server logs.

    And ask your host if they made any changes.

    They said they did not anything with their servers recently.
    I checked my error logs and did not find anything relevant to the problematic page (the network dashboard page) . I dont know what’s going on, it is very confusing, especially that it occurred without any change that I made.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    What happens if you save permalinks again?

    How can I save it ? I can’t access the network dashboard at all !

    I tried accessing wp-admin/upgrade.php , update, and update-core and I got the same results.
    Is there no way to reset something there ?
    What’s killing me is that the subsites and their dashboard are working great !

    Ipstenu I am relying on you with this 🙁
    I emailed my hosting support (who are usually very helpful) but they said they dont support WP MU (which I understand).

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Save your MAIN SITE’s permalinks.

    Thank you.

    That did not help either. what I did, I entered the permalinks and just clicked save. Tested , no change.

    Then selected “default” permalinks, saved, tested, no change either.

    Then reverted to the original setting “/blog/%year%/%monthnum%/%postname%/” but no change as well

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    FWIW, Resave means just go in and click save 😉 No changes needed.

    Search your site for a second .htaccess hiding out there.

    Yes I know that, and I did it first, and just made a change then saved again to make sure it went into effect 🙂

    In public_html there is only one htaccess file. is it a problem if other htaccess files were found in sub folders ?? will they be effective even if there is on hataccess in the public_html folder ?

    BTW, I have been using Chrome to log into
    http://SITE/wp-admin/network/index.php

    I went to IE 9 and pates the same link. At first I got “you dont have sufficient permissions” .. then refreshing, I got the 500 internal server error.

    As always I still can access
    http://SITE/wp-admin/
    which takes me to the main site’s dashboard, with no issues.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    is it a problem if other htaccess files were found in sub folders ?? will they be effective even if there is on hataccess in the public_html folder ?

    Well. Given that you should NEVER have physical subfolders with the same names as your sites, yes, that would totally cause issues.

    well I can say there is no such thing.
    There is a subfolder that contains the blogs that are still on the old subdomains (that I am combining into the network), but those are different in their names than the new subsites that I created in the network.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Okay good 🙂

    Do a weird thing… Run a repair and optimize on your DB?

    Did not help 🙁

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    This has all signs of ‘If you changed nothing but something changes’ then you grab your host by the ear and holler :/

    Hi again. This is what Hostmonster support replied with:

    I have setup the php settings on the account to default. I have also tried raising the limits substantially, from my investigations this does not seem to be the source of the issues you are having. Most likely this was caused by an upgrade or significant change you made to the wordpress multisite. When I try to replicate the issue I am not receiving a 500 error, or seeing a 500 error in the logs. It seems as though the script itself is broken but not producing errors. I recommend that you replace your wordpress multisite files inside your account with a new copy of wordpress multisite files, this should repair any incomplete or broken php files you currently have. If necessary I recommend using the wordpress support forums for further assistance (http://www.wordpress.org/support). Please let us know if you have further questions or need clarification on anything.

    So should I replace the files indeed? which files exactly?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    It can’t hurt. A manual upgrade is safe as houses.

Viewing 15 replies - 1 through 15 (of 42 total)
  • The topic ‘Network dashboard gives error 500, though main site and its adminCP load file’ is closed to new replies.