[resolved] Network Admin User and Site admin links don't work 3.1 (40 posts)

  1. kennibc
    Posted 5 years ago #

    I noticed that if I wanted to mark a blog or user as spam, delete them, or any of the other links that appear when you mouse over the title it doesn't work.

    The links for those options fail and promptly return me to the Network Dashboard. The only way I can mark a blog as spam is to use the Bulk Update Drop Down.

    Specifically I am talking about the links that appear when you mouse over a blog title or user name such as Edit, Spam, Delete, etc from the network admin panels.

    I briefly updated and when I saw how the admin search had been dumped and other little things I decided to go back to 3.05.

    Has anyone else tried to use these admin links yet? I hope I am not the only one!

    Any suggestions?

  2. Log off, flush your browser cookies, and log back on.

    Your cached credentials could be being stupid, I tested it on two sites with no problems.

  3. kennibc
    Posted 5 years ago #

    I did try that using google Chrome and flushing everything. However I did not try these links in another browser. I will have to try this on my next upgrade attempt.

    Any other suggestion?

  4. Yeah, the normal ones :)

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Ten theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - If all else fails, manually upgrade. Download a fresh copy of the latest.zip file of 3.1 (top right on this page) to your computer, and use that to copy up. You may need to delete the wp-admin and wp-includes folders on your server. Read the Manual Update directions first!

  5. kennibc
    Posted 5 years ago #

    I am going to try it out again tomorrow.

  6. On the user menu, hovering over the username just gave me and edit link and something else.checking the box, then picking "mark as spam" looked like it worked and... then did not.

    Yeah, on my test install running a butt-load of plugins.

  7. Hover over ONLY has edit and delete now that I can see. The drop down has 'em all.

    Marking as spam I remember being broken at some point in the testing... Just tested and it works for me. Found another spammer, worked fine again.

    Deleted a user from the hover-link, worked fine.

  8. yeah I wonder what plugin is borking the "mark as spam".

  9. kennibc
    Posted 5 years ago #

    Here are my plugins. Maybe you have one of the same that may be the culprit:

    All in One Video Pack
    All in One Video Pack Sidebar Widget
    BP Group Calendar
    BP Group Documents
    BuddyPress Links
    BuddyPress Moderation
    BuddyPress Wiki Component
    Community Blogs
    Content Monitor
    Limit Blogs per User
    NextGEN Gallery
    oEmbed for BuddyPress
    Private BuddyPress
    Remove WP Dashboard Widgets
    Subscribe by Email
    WPMU DEV Update Notifications
    WP Super Edit
    WP Super Edit Theme Classes
    WP Super Edit WordPress Emoticons

    Must Use WPMU:
    Additional Tags
    Admin Footer Text
    Easy Blogging Tooltips
    LDAP Authentication Plug-in
    Sitewide Privacy Options for WordPress Multisite
    Toggle Admin Menus
    Wordpress MU Plugin Filter
    WPMU Power Tools

  10. Wow. The number of plugins with which I am not familiar....

    Okay, it's NOT:
    oEmbed for BuddyPress
    Subscribe by Email

    Those are the only ones I've used from your list. I THINK BuddyPress Links is okay too, but I only used it for a day.

    I would turn off ALL plugins related to moderation and privacy, JUST to test :/

  11. kennibc
    Posted 5 years ago #

    OK. I turned off every plugin before running the update to 3.1 except for Buddypress. Performed the update and then immediately updated Buddypress. Then I did the Update Network to touch all the blogs.

    After about 15 minutes the links in the Network Admin panel started working properly. By this time I had re-activated all the plugins.

    Still monitoring it.

  12. Fingers crossed! It may be as simple as a plugin needed to be reactivated to work 'right'.

  13. kennibc
    Posted 5 years ago #

    Here is the problem in detail. It does work as long as you do not use the search!

    If you go to the network admin page and click on Sites it will display the Sites. All of these links work fine as you go through the various pages. Edit, delete, Spam, etc all work correctly.


    But if you SEARCH for a blog the link changes:

    Notice that in the search links that it includes the subdirectory for the blog url. In this example the /forengage/ is the blog URL which causes the buttons to not work.

    I hope this can help in fixing the issue.

  14. Interesting. I don't see that on my subdomain blog.

  15. kennibc
    Posted 5 years ago #

    This is all done from the main blog, under network administration panel and specifically the SITE and USER panels where it lists all your multisite blogs and users.

    As super admin if I go to http://domain.com/wp-admin/network/sites.php I can see and manage all subsites in my multisite setup.

    However, if I do a search for a blog, the management links are all broken as explained in the message above because the search form adds the subdirectory into the management links such as edit, visit, spam, delete, etc.

    Does this make any sense or did my install not upgrade properly?

  16. kennibc
    Posted 5 years ago #

    Here is a Jing Screen capture explaining what happens.

  17. However, if I do a search for a blog, the management links are all broken as explained in the message above because the search form adds the subdirectory into the management links such as edit, visit, spam, delete, etc.

    While I coudl reproduce your other issue, I could NOT reproduce this one.

    After searching for some sites, the listing appeared fine on my install.

    Have you disabled every single plugin, including any in mu-plugins?

  18. Sorry, what I mean is when I log into my site that uses subdomains, I do not see this error. What Andrea said, basically.

  19. kennibc
    Posted 5 years ago #

    So it works for subdomains and not subdirectory setups?

    Could this be some type of htaccess redirect that is missing?

  20. kennibc
    Posted 5 years ago #

    And here is another issue... If I do a wildcard search in keeping with the above Jing screen capture for "weeks*" the URL generated for each of the blog managment links are built like this:

    Notice how the links are made using my search term with a % character for the wildcard *.

    This is a weird one for sure with sub directories.

  21. kennibc
    Posted 5 years ago #

    Funny thing is if I delete the "%" character and hit refresh it does what the link was intended to do such as delete, mark as spam, etc.

    This might be a bug that was overlooked specifically for sub directories.

  22. Bounced over to my sub directory install...

    I can repro the sites issues on a sub directory install. I cannot repro the users issues on either.

    Okay http://core.trac.wordpress.org/ticket/16720

  23. kennibc
    Posted 5 years ago #

    The patch in the trac works just fine even with the wildcards.

  24. Thank @greuben ! :) Glad it worked, this should make it in 3.1.1

    *sigh* Wish we'd caught some of these in RCs man.

  25. bunnyflo
    Posted 5 years ago #

    Hi there, after the wordpress update to 3.1 I now have 2 admin sections. :>/ I only have one social network site, not multiple sites. I do not believe I need a super admin section, can I turn this off?

  26. Looks under Network Admin -> Sites. How many are listed?

  27. bunnyflo
    Posted 5 years ago #

    Thank you Andrea, I only have one site and that is all that is listed..

  28. @bunnyflo are you also using buddypress? I'm wondering why you have the network enabled and only one site.

    It's for letting you & your users have blogs.

  29. bunnyflo
    Posted 5 years ago #

    Yes I am using buddypress however it was the 3.1 wordpress update that changed the super admin section. I did not enable the network for users to have websites but I have groups activated. I believe in the wordpress 3.1 this is not an option to turn it off as cannot find any section that specifically is for this or any info online.

  30. I did not enable the network for users to have websites but I have groups activated.

    BuddyPress groups SHOULD work in SingleSite. All of BuddyPress works in SingleSite to the best of my understanding.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.