WordPress.org

Support

Support » Multisite » Network Admin links point incorrectly

Network Admin links point incorrectly

  • Hello, I reviewed other topics that are similar but I still cannot resolve the issue.
    I have a fresh install of WP 3.5 on localhost in its own directory. Before adding multisite, I ensured that I can browse the blog and use the admin. Using TwentyTwelve theme and the plugins are already deactivated. No problems.
    Then I enabled multisite and set up the network, created the blogs.dir, updated the wp-config and .htaccess files with the content displayed in the process. Everything continues to work except the Network Admin links have the wrong path. Not sure how to fix this.

    URL for blog: localhost/dev/owp
    WP admin: localhost/dev/owp/wordpress/wp-admin
    Network Admin links start with: localhost/dev/owp/wp-admin

    my .htaccess file…

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /dev/owp/
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) C:\xampp\htdocs\dev\owp\wordpress/$2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ C:\xampp\htdocs\dev\owp\wordpress/$2 [L]
    RewriteRule . index.php [L]
    </IfModule>
    # END WordPress

    I also tried setting ReWriteBase to /

    network_admin_url() resolves to: http://localhost/dev/owp/wp-admin/network/
    get_admin_url() resolves to: http://localhost/dev/owp/wordpress/wp-admin/

    What could I be overlooking? Thanks in advance.

Viewing 10 replies - 1 through 10 (of 10 total)
Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Network Admin links point incorrectly’ is closed to new replies.
Skip to toolbar