WordPress.org

Support

Support » Multisite » [Resolved] "Network Admin" link redirecting to "http://wp-admin/network/"

[Resolved] "Network Admin" link redirecting to "http://wp-admin/network/"

Viewing 15 replies - 1 through 15 (of 26 total)
  • Andrea Rennick

    @andrea_r

    Customer Care at Copyblogger Media and Studiopress

    Could be a plugin conflict tho. I;d start by checking db values to make sure every place that needs to save the domain name actually has it in place.

    Okay, thanks. Where specifically in the database should I be checking?

    wp_site, wp_sitemeta, wp_options (and really all wp_X_options)

    1. wp_site: domain = http://www.abetterworldbydesign.com | path = /
    2. wp_sitemeta: meta_value[siteurl] = http://www.abetterworldbydesign.com/
    3. wp_options: option_name[siteurl] = http://www.abetterworldbydesign.com
    4. wp_3_options: option_name[siteurl] = http://www.abetterworldbydesign.com/2010/

    wp_3 represents the only other WordPress blog (other than the root) that I currently have in this install of WP Multisite.

    Only discrepancy I noticed is that #2 has a trailing slash and #3 does not. Not sure what these values should be specifically, but everything looks as expected with my limited knowledge of what the database should look like.

    I’ve been communicating with tech support at my web host about this. They’ve looked into things, and they’ve been stumped. Here’s the info they provided me from what they found though.

    “The issue here is that the value returned by network_admin_url(); when called by your blog isn’t correct. I’m not sure where or how this is stored in your database.”

    Any idea where the value returned by network_admin_url(); is stored in the database?

    Andrea Rennick

    @andrea_r

    Customer Care at Copyblogger Media and Studiopress

    Any idea where the value returned by network_admin_url(); is stored in the database?

    It’s built on the fly.

    What’s the value in wp-config.php for DOMAIN_CURRENT_SITE?

    define( ‘DOMAIN_CURRENT_SITE’, ‘www.abetterworldbydesign.com’ );

    Might check your htaccess, it prolly rewrite wrong aswell.

    Whats the value in wp-config of patch_current_site, site_id & blog_id_current_site ?

    .htaccess code:

    # BEGIN WordPress
    Options +FollowSymLinks
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    select lines from wp-config.php:

    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'www.abetterworldbydesign.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    And you have define('WP_ALLOW_MULTISITE', true); in there too? Shouldn’t matter but…

    Andrea Rennick

    @andrea_r

    Customer Care at Copyblogger Media and Studiopress

    wp_site: domain = http://www.abetterworldbydesign.com | path = /

    this table should not have the http:// in it.

    It may not (the forums add it in if you put www . domain . com in :/ )

    @ipstenu – good call. The forum did add the http:// to my value for wp_site: domain. It actually reads www(dot)abetterworldbydesign(dot)com in the database.

    As for WP_ALLOW_MULTISITE, the support team at HostGator did some tinkering with it. that line currently reads:

    define( 'MULTISITE', true ); //hg commented this, to be replaced by next line:
    //define( 'WP_ALLOW_MULTISITE', true );

    Toggling the commented lines to:

    //define( 'MULTISITE', true ); //hg commented this, to be replaced by next line:
    define( 'WP_ALLOW_MULTISITE', true );

    causes a “Error establishing database connection” message in the browser.

    Here’s my entire wp-config.php in pastebin (secure items replaced with “###”).

    Try this:

    define( 'MULTISITE', true );
    define( 'WP_ALLOW_MULTISITE', true );

    Yes, both.

    Thanks all for the replies. Okay, I’ve changed those lines in wp-config.php to

    define( 'MULTISITE', true );
    define( 'WP_ALLOW_MULTISITE', true );

    I’ve also updated it in pastebin.

    The front end of the site is behaving normally, but I’m still having the issue originally described with the “network admin” URL.

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘[Resolved] "Network Admin" link redirecting to "http://wp-admin/network/"’ is closed to new replies.
Skip to toolbar