Support » Networking WordPress » network admin getting redirect loop

  • Resolved hemant.sathe



    I have multiple blogs for past more than a year using WPMU. Recently when I upgraded to 3.1, I noticed that the super admin menu is replaced by network admin and when I tried to access the network admin, I am getting redirect loop basically for all URLs starting with /wp-admin/network. I have tried all options like disabling all plugins, removing all plugins, reinstalling fresh copy of 3.1 and changing the config file, reinstalling plugins, installing plugins to block canonical redirects. But so far nothing has worked. The blogs are working OK (have not done extensive testing) but things look good. Only in case of wp-admin/network/* I am getting the redirect loop. Can some one help? Thanks in advance.


Viewing 15 replies - 1 through 15 (of 30 total)
  • BTW, I am hosting site on I am the only user and administrator. Not sharing the URL yet since only network admin function is affected.


    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Plugin Review Team Rep

    What’s the content of your .htaccess?

    I know partly this will be futile, but you’ll have to ask GoDaddy support for help.

    on some servers, any foldders under wp-admin are getting ignored.

    Got some resolution. Commented out following code present in wp-config.php

    /*$base = '/';
    define('DOMAIN_CURRENT_SITE', '' );
    define('PATH_CURRENT_SITE', '/' );
    define('BLOGID_CURRENT_SITE', '1' );
    define('NOBLOGREDIRECT', '');*/

    Still testing if everything is OK. But do we need this code for something else? Should I uncomment some part of it?


    define(‘NOBLOGREDIRECT’, ‘’);

    you might still want this bit. but uncommenting the rest shoudl be okay if new blog creation still works fine.

    It’s actually part of the install process when you do multi-networks (uncommenting those lines).

    Had simular issue when upgrading from 3.1 to 3.1.1.

    Tried to disable the lines suggested and found the line that caused the issue.
    For me, the setting of:
    define(‘DOMAIN_CURRENT_SITE’, ‘www.domain.tld’ );
    had some issues with the www in front of the domain. Removed the www. and network admin worked again.

    … had some issues with the www in front of the domain. Removed the www. and network admin worked again.

    Same here!
    Problem solved

    I just found this answer in the WordPress bug Trac. Applying the code update worked for me.

    Multisite 3.1.1 Upgrade Redirect Loop Network Admin & Plugins
    (modifed the code in the file “admin.php” in the path “/wp-admin/network”)

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Plugin Review Team Rep

    The ‘code update’ in that ticket is a bad idea. Why? Well it’s flagged INVALID, which means updates will overwrite it.

    The ticket also noted it was ruled out as a bug.

    I’ve got this same issue. I’ve tried everything that has been mentioned in the posts above but to no avail.

    The main difference is that I’m running WP as an internal company intranet, so it’s on a local webserver which isn’t accessible externally.

    I have the following in my config file, and commenting out doesn’t help:

    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    define('VHOST', 'yes');
    $base = '/subdir/';
    define('DOMAIN_CURRENT_SITE', '' );
    define('PATH_CURRENT_SITE', '/subdir/' );
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOGID_CURRENT_SITE', '1' );

    Removing the www in this line:

    define('DOMAIN_CURRENT_SITE', 'www.domain.tld' );

    Worked for me. Doesn’t appear to have adversely affected anything else yet.

    WAIT. Not true.

    Without the www, I’m no longer able to create new sites in my network. My guess is that the abset www invalidates the nonce somehow, and it won’t let me proceed.

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Plugin Review Team Rep

    Shouldn’t be related to the nonce, but dump all your cookies and log back in.

    I’m having the same problem…
    removing the www from define('DOMAIN_CURRENT_SITE', 'www.domain.tld' ); worked…
    now part of the network admin is redirected to the non-www version of the domain…
    is this a bug or something that will be switched back at some point (www.domain.tld network admin available again)?

    Thanks 🙂


Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘network admin getting redirect loop’ is closed to new replies.