Support » Networking WordPress » Network admin cannot log into wordpress main site due to not enough memory?

  • Dear all,

    I’m now headache with one problem: recently I installed wordpress 3.5.1 with multisite. However, my colleague told me that the memory is exhausted and even now I cannot get access into wp-admin. The following is the information about the server that the wordpress is located:

    Memory: 2GB
    Wordpress version: 3.5.1
    Memory left: mainly 150-200MB
    Plugins used: buddypress, GD star Rating, add-multiple-users, user-role-editor, multisite-user-management, new blog defaults
    No. of subsites: 218, with only about 20 subsites are now working.

    I do hope that I can find a method to get access to wp-admin again so that I can disable the plugin of GD star rating and undergo some privacy settings.

    Also, I wish to know is there any method of making wordpress to release the memory automatically after the user logs out? Thanks a billion!

Viewing 15 replies - 1 through 15 (of 16 total)
  • You can easily deactivate any plugin via FTP. Login to your server via FTP and go to wp-content > plugins and just delete the plugin you want.

    But the scared thing is, being a network administrator, I cannot log into wordpress, but for the subsite users, they can log into it. I don’t know what it really happens? Feel frustrated now…….

    Very strange indeed.

    I’ll move this thread to the multisite section and hopefully someone in that area may have experienced this.



    Forum Moderator

    Just a thought but “memory” is not the same as “PHP memory”. You need to see what memory is being made available to PHP via the server’s php.ini file.

    I agree with esmi – You may be running out of PHP Memory (BuddyPress does this easily on some hosts).

    Thanks for all replies first. Now the multisite has been transferred to one another new server with more memory (4GB now). Then I tried to modify and test the multisites, finding that even though sometimes the memory usage has been jumped up from 1.3 GB to around 2 GB, it dropped down quickly to ab out 1.4 GB again. Hopefully it can be alright then.

    However, one another problem occurred–once I moved the multisite from one server to another server, even I changed the urls for all required values, such as posts, options, home and site urls and comments, I don’t know why the subsites and images cannot show properly. Also, it is found that the mysql process has undergone, but I could not find out what mysql process is undergoing. So how can I fix such problem? Thanks!

    Server memory is not the same as PHP memory. Ask your hosts how to bump that for one.

    And ask them if httpd.conf has AllowOverride set to ALL on your new server.

    Ipstenu, I’ve asked the host to have AllowOverride set to ALL, but the situation is still the same. Is it related to the themes? The situation is the main site is using buddypress, and then subsites are using twenty twelve. I wish to know that whether settings should be changed in some files in themes, or just check the php memory directly to fix such problem. Thanks again!

    No it’s probably not themes.

    If you could actually provide us with links to the sites in question, we might be able to give you more precise advice.

    As the wordpress multisite is placed in the server that is accessed for internal testing only at this moment, I cannot provide the link for you to access. Instead, I uploaded two pictures in the sendspace for you to see what it really happens.
    This is the mainsite using buddypress.
    This is one of the subsite using twenty twelve.

    Hope these can help. Thanks!

    Well some of the images work, I see. The theme ones, just not uploaded images.

    What’s in your .htaccess?

    And is allowOverride set to ALL (or Options All) in your httpd.conf?

    Actually, the main site’s background and header images work well, but not for the subsites’ avatars and images uploaded. The following is the .htaccess of the multisite.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /demo/wordpress/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /demo/wordpress/index.php [L]
    # END WordPress
    # New Setting
    # add a trailing slash to /wp-admin
    #<IfModule mod_rewrite.c>
    #RewriteEngine On
    #RewriteBase /demo/wordpress/
    #RewriteRule ^index\.php$ - [L]
    #RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    #RewriteCond %{REQUEST_FILENAME} -f [OR]
    #RewriteCond %{REQUEST_FILENAME} -d
    #RewriteRule ^ - [L]
    #RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    #RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    #RewriteRule . index.php [L]

    The point here is, if I do not comment the lower part and comment the upper part (without comment ones) instead, there will be an permission error. So I don’t know what it really happens.

    For the httpd.conf one

    <IfModule mod_include.c>
        <Directory "/var/www/error">
            AllowOverride None
            Options IncludesNoExec
            AddOutputFilter Includes html
            AddHandler type-map var
            Order allow,deny
            Allow from all
            LanguagePriority en es de fr
            ForceLanguagePriority Prefer Fallback
        <Directory "/var/www/html/demo/wordpress">
            AllowOverride All
            Allow from all

    Hope the above can help. Thanks!

    Try this:

    <Directory "/var/www/html/demo/wordpress">
            AllowOverride Options All
            Allow from all

    Tried to change, but the result is the same. So is it related to .htaccess instead of httpd.conf?

    I also tried to get into one subsite’s dashboard through network admin panel, by going through My Sites>Network Admin>Sites, then choose the subsite’s dashboard I wish to go, but then it shows the front page of the blog without header of admin panel, as shown in the second picture I attached.

    Hope the above information can be helpful for finding out what happened. Thanks!

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Network admin cannot log into wordpress main site due to not enough memory?’ is closed to new replies.