Support » Alpha/Beta/RC » Network Activating Plugins not working?

  • I’ve been trying to find an answer to this question on google and the codex and just can’t.

    I’ve just downloaded 3.0-beta 2 to try out the multi-site functionality. I’m running it on localhost, using subdirectories. I’ve got that part working.

    Now, I’m trying to get some plugins showing up across the different sites. I network activate the plugins, but when I login to the usersites, I can’t see them in the Plugin menu (I have “Enabled Administration Menus” checked in the Super Admin Options).

    3.0 is installed in localhost/dev/wp3
    User1 is localhost/dev/wp3/user1

    Logged in as a superadmin, I network activated a plugin (Thesis Openhook, if that makes a difference). When I go to localhost/dev/wp3/user1/wp-admin and login as user1, I see the Plugins menu, I even see that there is (1) Network Plugin, but Thesis Openhook does not show up either on the list of Active plugins or Network plugins, nor does it appear to be activated. Same behaviour on “Sharing is Sexy”.

    I feel like I’m missing something very simple, but I can’t figure it out. Can anyone help?

    How do I get network activated plugins to show up for admin users on the child sites?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Bump.

    Maybe it’s a dumb question, but if it is, the answer must be simple.

    Not every plugin works on a network activation. You may have to address each plugin individually with their devs.

    Also don’t bump, please. Tis against forum guidelines.

    Sorry about that. New to the forum. Didn’t mean to offend. But thanks for the reply.

    I tried installing and Network Activating BuddyPress (that’s a MU compatible plugin, right?) and the same behaviour. On the child site, the number of “Network Plugins” (on the Manage Plugins page) increased, but BuddyPress doesn’t show up in the list. I would think that it should….

    I’d re-upload all the files for WordPress as, yes, that should work.

    It’s a fresh install of WP3-beta2.

    Maybe it’s a beta issue. Good to hear I’m not crazy.

    It’s not a beta issue unless it’s that Beta2 is bad. I used it, but I’m on the nightly right now. Try this:

    I did some poking around. It turns out there’s a line in the print_plugins_table that makes it so network activated plugins are ignored unless it’s the superadmin logged in. Around line 560 of wp-admin/plugins.php is:

    if ( $is_active_for_network && !is_super_admin() )

    So, I guess it’s by design that network activated plugins don’t show up for admin users on the child sites. I tried going back to the super_admin dashboard and un-network activating the plugins, then just simply activating them. Then they appear in the child site dashboards and the child site admin and activate them as he wishes.

    Behaviour was still a little strange though. First off, the above doesn’t work for BuddyPress (you can ONLY Network activate BuddyPress). Second off, when I activated Thesis Openhook on a child site, my Thesis Openhook settings menu option under appearance doesn’t show up. Further, when I made Thesis the active theme on the child site, the Thesis menu option doesn’t show up. Now those may well be problems specific to that plugin/theme. I can look into that.

    I guess this is all a case of not completely understanding Network Activation of plugins. It seems that these are the rules (listed here in case someone else finds this thread with the same questions I had):

    1. Network Activated plugins are available and activated on all child sites. Further:
    2. They don’t show up in the list of Plugins (though the number of Network Plugins does indeed show up). Perhaps it would be better if a list of Network Plugins showed up, but without the ability to activate/deactivate/edit them.
    3. The settings pages (if the plugin is properly setup to run in MU) _do_ appear under the settings menu
    4. Simply Activated plugins in the parent site appear in the list of available plugins on the child sites. The child sites have the ability to activate/deactivate them and change the settings

    Sound right to you?

    I have to admit, I only ever log in with my SuperGro— SuperADMIN account. But that makes sense really. A regular admin wouldn’t have the ability to turn off network plugins. I think your #2 is a good idea.

    Regarding #4, by ‘Simply Activated plugins’ you mean normal per-site plugins, right? There are also MU (Must Use) plugins.

    when I made Thesis the active theme on the child site, the Thesis menu option doesn’t show up.

    What plugins are you using?

    Back at ‘er….

    Yes for #4, I mean normal per-site plugins. I haven’t even approached MU plugins yet (I guess the meaning behind MU depends on the context it’s being used in).

    As for what plugins I’m using, it’s a clean install, just playing around with it. Right now I only have BuddyPress, Sharing is Sexy and Thesis OpenHook installed. I’m pretty sure the Thesis menu option not showing up has to do with the Thesis theme.

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    “Perhaps it would be better if a list of Network Plugins showed up, but without the ability to activate/deactivate/edit them.”

    On many, many sites currently running MU, the Super Admin do not want this ability ,. Nuh uh, no way. 🙂

    As you’re finding, some plugins are not built with multi-site in mind. If it doesn’t say to Network activate or put it in the mu-plugins folder (which stands for must-use by the way) then activate it one by one.

    Would it make sense to remove the “Network” plugins tab altogether for child admins? It seems a little strange to tease with the number of network plugins activated, yet not show them which ones.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Network Activating Plugins not working?’ is closed to new replies.