Support » Plugin: WORDPRESS VIDEO GALLERY » Net connection not available in your system

Viewing 15 replies - 1 through 15 (of 19 total)
  • arunprasath

    (@arunprasath)

    Apptha plugin contributor

    Hi Dan,

    Sorry for the inconvenience. I understand that you have problems in playing YouTube Videos through our player. YouTube has stopped support for the flash player API and that is the reason it is not working. We are aware of this issue and we are working to make the YouTube videos to play through YouTube player instead of flash player.

    We will update the solution to you shortly.

    arunprasath

    (@arunprasath)

    Apptha plugin contributor

    Hi Dan,

    Please follow the below steps to resolve the issue with “Net Connection not available” This solution will help you play the YouTube videos through YouTube player instead of Flash player as YouTube has stopped support for Flash player and upgraded to Iframe.

    1.go to FTP in the file path ../wp-content/plugins/contus-video-gallery/front/views/videohome.php and open file videohome.php

    ​​Search for the​ ​code

    /** If browser is detect then play videos via flash player using embed code */
    $div .= ‘<embed id=”player” src=”‘ . $swf . ‘” flashvars=”baserefW=’ . $this->_siteURL . $baseref . $showplaylist . ‘&mtype=playerModule” width=”‘ . $settingsData->width . ‘” height=”‘ . $settingsData->height . ‘” allowFullScreen=”true” allowScriptAccess=”always” type=”application/x-shockwave-flash” wmode=”transparent” />’;

    ​​Replace it with

    if (strpos ( $videoUrl, ‘youtube’ ) > 0) {
    /** Iframe code for youtube videos */
    $videoId1 = getYoutubeVideoID ( $videoUrl );
    $div='<div id=”player”></div><script>var tag = document.createElement(“script”);tag.src = “https://www.youtube.com/iframe_api”;var firstScriptTag = document.getElementsByTagName(“script”)[0];firstScriptTag.parentNode.insertBefore(tag, firstScriptTag);var player;function onYouTubeIframeAPIReady() {player = new YT.Player(“player”, {width: “‘.$settingsData->width .'”,height: “‘.$settingsData->height .'”,videoId: “‘.$videoId1.'”,playerVars: {“rel”: 0,”showinfo”:0,”modestbranding”:0},events: {“onStateChange”: onPlayerStateChange}});}var done = false;function onPlayerStateChange(event) {if (event.data == YT.PlayerState.PLAYING && !done) {currentVideoP(‘.$videoId.’);done = true;}}</script>’;
    } else{
    /** If browser is detect then play videos via flash player using embed code */
    $div .= ‘<embed id=”player” src=”‘ . $swf . ‘” flashvars=”baserefW=’ . $this->_siteURL . $baseref . $showplaylist . ‘&mtype=playerModule” width=”‘ . $settingsData->width . ‘” height=”‘ . $settingsData->height . ‘” allowFullScreen=”true” allowScriptAccess=”always” type=”application/x-shockwave-flash” wmode=”transparent” />’;
    }

    Save the file.

    2.​ ​then go to ./wp-content/plugins/contus-video-gallery/front/views/videodetailpage.php and open the file videodetailpage.php

    ​​Search for the line

    $output .= ‘<div id=”flashplayer”><embed src=”‘ . $this->_swfPath . ‘” flashvars=”‘ . $flashvars . ‘” width=”‘ . $width . ‘” height=”‘ . $height . ‘” allowfullscreen=”true” allowscriptaccess=”always” type=”application/x-shockwave-flash” wmode=”transparent”></div>’;
    ​​
    Replace it with

    foreach ( $fetched as $media ) {
    $videourl = $media->file;
    $file_type = $media->file_type;
    $imgurl = getImagesValue ( $media->image, $file_type, $media->amazon_buckets, ”);
    }
    if (strpos ( $videourl, ‘youtube’ ) > 0) {
    $videoid = getYoutubeVideoID ( $videourl );
    $output .='<div id=”player”></div><script>var tag = document.createElement(“script”);tag.src = “https://www.youtube.com/iframe_api”;var firstScriptTag = document.getElementsByTagName(“script”)[0];firstScriptTag.parentNode.insertBefore(tag, firstScriptTag);var player;function onYouTubeIframeAPIReady() {player = new YT.Player(“player”, {width: “‘.$width.'”, height:”‘.$height.'”,videoId: “‘.$videoid.'”,playerVars: {“rel”: 0,”showinfo”:0,”modestbranding”:0},events: {“onStateChange”: onPlayerStateChange}});}var done = false;function onPlayerStateChange(event) {if (event.data == YT.PlayerState.PLAYING && !done) {currentVideoP(‘.$videoId.’);done = true;}}</script>’;

    /** Generate youtube embed code for html5 player */
    } else{

    $output .= ‘<div id=”flashplayer”><embed src=”‘ . $this->_swfPath . ‘” flashvars=”‘ . $flashvars . ‘” width=”‘ . $width . ‘” height=”‘ . $height . ‘” allowfullscreen=”true” allowscriptaccess=”always” type=”application/x-shockwave-flash” wmode=”transparent”></div>’;

    3. Now Save the file.

    If you are using Video stream theme follow the below steps as well

    Steps to solve the issue in Video Stream theme home page banner player.

    1. Go to the file path: wp-content/themes/videostream/html/widgets/contusBannerSlideshow.php

    Find the below lines

    <embecontus
    src=”<?php echo $site_url.’/wp-content/plugins/’.$pluginName.’/hdflvplayer/hdplayer.swf’; ?>”
    flashvars=”baserefW=<?php echo $site_url; ?>&banner=true&mtype=playerModule&vid=<?php echo $bannerSlideShow[$i]->vid; ?>&<?php echo $baseref; ?>&Preview=<?php echo $bannerSlideShow[$i]->image; ?>”
    style=”width:672px; height: 315px” allowFullScreen=”true”
    allowScriptAccess=”always” type=”application/x-shockwave-flash”
    wmode=”transparent”></embecontus>

    replace with

    <?php $videourl = $bannerSlideShow[$i]->file;
    $_imagePath = APPTHA_VGALLERY_BASEURL . ‘images’ . DS;
    $image_path = str_replace(‘plugins/contus-video-gallery/’, ‘uploads/videogallery/’, APPTHA_VGALLERY_BASEURL);
    $imgurl = $bannerSlideShow[$i]->image;
    $file_type = $bannerSlideShow[$i]->file_type;
    if ($imgurl == ”) { ## If there is no thumb image for video
    $imgurl = $_imagePath . ‘nothumbimage.jpg’;
    } else {
    if ($file_type == 2) { ## For uploaded image
    $imgurl = $image_path . $imgurl;
    }
    }

    if (preg_match(‘/www\.youtube\.com\/watch\?v=[^&]+/’, $videourl, $vresult))
    {
    $urlArray = explode(“=”, $vresult[0]);
    $videoid = trim($urlArray[1]);
    ?>
    <iframcontus type=”text/html” width=”672″ height=”315″ src=”http://www.youtube.com/embed/<?php echo $videoid; ?>” frameborder=”0″>
    </iframcontus>

    <?php } else { ?>

    <embecontus
    src=”<?php echo $site_url.’/wp-content/plugins/’.$pluginName.’/hdflvplayer/hdplayer.swf’; ?>”
    flashvars=”baserefW=<?php echo $site_url; ?>&banner=true&mtype=playerModule&vid=<?php echo $bannerSlideShow[$i]->vid; ?>&<?php echo $baseref; ?>&Preview=<?php echo $bannerSlideShow[$i]->image; ?>”
    style=”width:672px; height: 315px” allowFullScreen=”true”
    allowScriptAccess=”always” type=”application/x-shockwave-flash”
    wmode=”transparent”></embecontus>
    <?php } ?>

    Thanks for your fast answer. I made replacements but I get:
    Parse error: syntax error, unexpected ‘”’ (T_STRING) in /home3/danca/public_html/wp-content/plugins/contus-video-gallery/front/views/videohome.php on line 261
    and I replaced ” and ’ with ” and ‘
    Now I get this:
    Parse error: syntax error, unexpected ‘player’ (T_STRING) in /home3/danca/public_html/wp-content/plugins/contus-video-gallery/front/views/videodetailpage.php on line 459

    arunprasath

    (@arunprasath)

    Apptha plugin contributor

    Hi Dan,

    Could you please confirm the Video Gallery version you are using, so we will be able to help you.

    Version 3.0.

    arunprasath

    (@arunprasath)

    Apptha plugin contributor

    Hi Dan,

    Please download the latest package from https://wordpress.org/plugins/contus-video-gallery/ in your desktop and copy the files videohome.php and videodetailpage.php from file paths contus-video-gallery\front\views and replace the files in your server in the same file path /wp-content/plugins/contus-video-gallery/front/views/.

    Ensure you backup the files before replacing.

    I did. “Net Connection not available” is still there.
    Then I replaced also the suggestion you made for videohome.php file and I get this: Parse error: syntax error, unexpected ‘baserefW’ (T_STRING) in /home3/danca/public_html/wp-content/plugins/contus-video-gallery/front/views/videohome.php on line 306

    arunprasath

    (@arunprasath)

    Apptha plugin contributor

    Hi Dan,

    I noticed that the in the first steps we have provided missing a close brace } in else condition.

    It should be like 2.​ ​then go to ./wp-content/plugins/contus-video-gallery/front/views/videodetailpage.php and open the file videodetailpage.php

    ​​Search for the line

    $output .= ‘<div id=”flashplayer”><embed src=”‘ . $this->_swfPath . ‘” flashvars=”‘ . $flashvars . ‘” width=”‘ . $width . ‘” height=”‘ . $height . ‘” allowfullscreen=”true” allowscriptaccess=”always” type=”application/x-shockwave-flash” wmode=”transparent”></div>’;
    ​​
    Replace it with

    foreach ( $fetched as $media ) {
    $videourl = $media->file;
    $file_type = $media->file_type;
    $imgurl = getImagesValue ( $media->image, $file_type, $media->amazon_buckets, ”);
    }
    if (strpos ( $videourl, ‘youtube’ ) > 0) {
    $videoid = getYoutubeVideoID ( $videourl );
    $output .='<div id=”player”></div><script>var tag = document.createElement(“script”);tag.src = “https://www.youtube.com/iframe_api”;var firstScriptTag = document.getElementsByTagName(“script”)[0];firstScriptTag.parentNode.insertBefore(tag, firstScriptTag);var player;function onYouTubeIframeAPIReady() {player = new YT.Player(“player”, {width: “‘.$width.’”, height:”‘.$height.’”,videoId: “‘.$videoid.’”,playerVars: {“rel”: 0,”showinfo”:0,”modestbranding”:0},events: {“onStateChange”: onPlayerStateChange}});}var done = false;function onPlayerStateChange(event) {if (event.data == YT.PlayerState.PLAYING && !done) {currentVideoP(‘.$videoId.’);done = true;}}</script>’;

    /** Generate youtube embed code for html5 player */
    } else{

    $output .= ‘<div id=”flashplayer”><embed src=”‘ . $this->_swfPath . ‘” flashvars=”‘ . $flashvars . ‘” width=”‘ . $width . ‘” height=”‘ . $height . ‘” allowfullscreen=”true” allowscriptaccess=”always” type=”application/x-shockwave-flash” wmode=”transparent”></div>’;
    }

    The steps provided for videohome.php does not have any changes and you can use the same code provided earlier.

    I replaced exactly strings you provided above. The error still there:
    Parse error: syntax error, unexpected ‘player’ (T_STRING) in /home3/danca/public_html/wp-content/plugins/contus-video-gallery/front/views/videodetailpage.php on line 459

    I am having the same exact problem, I am only adding my comment here to receive a notification when the thread is updated.

    Here is the link for son’s website showing the problem.

    Thank you,

    • This reply was modified 1 year, 8 months ago by  rcktech.
    • This reply was modified 1 year, 8 months ago by  rcktech.

    Any news??

    arunprasath

    (@arunprasath)

    Apptha plugin contributor

    Hi,

    Please download the files videodetailpage.php and videohome.php from below links and replace them in the following file path /wp-content/plugins/contus-video-gallery/front/views/ from your FTP. Ensure you back up the existing files before you replace it.

    https://www.dropbox.com/s/eyokmdssjamtnkd/videodetailpage.php?dl=0

    https://www.dropbox.com/s/3phzy2krjaui59a/videohome.php?dl=0

    I did it, I got the following error

    Parse error: syntax error, unexpected T_USE, expecting T_FUNCTION in /home2/rcktec/public_html/guitarbydimitri.com/wp-content/plugins/contus-video-gallery/front/views/videohome.php on line 27

    then I decided to see if I would revert only one of the files to see which one is culprit, I reverted videohome.php to it’s original file and kept the new videotailpage.php I got the following error:

    Warning: include_once(/home2/rcktec/public_html/guitarbydimitri.com/wp-content/plugins/contus-video-gallery/front/views/videohome.php) [function.include-once]: failed to open stream: No such file or directory in /home2/rcktec/public_html/guitarbydimitri.com/wp-content/plugins/contus-video-gallery/front/controllers/videohomeController.php on line 123
    Warning: include_once() [function.include]: Failed opening ‘/home2/rcktec/public_html/guitarbydimitri.com/wp-content/plugins/contus-video-gallery/front/views/videohome.php’ for inclusion (include_path=’.:/opt/php53/lib/php’) in /home2/rcktec/public_html/guitarbydimitri.com/wp-content/plugins/contus-video-gallery/front/controllers/videohomeController.php on line 123
    Warning: Cannot modify header information – headers already sent by (output started at /home2/rcktec/public_html/guitarbydimitri.com/wp-content/plugins/contus-video-gallery/front/controllers/videohomeController.php:123) in /home2/rcktec/public_html/guitarbydimitri.com/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 62
    Warning: session_start() [function.session-start]: Cannot send session cache limiter – headers already sent (output started at /home2/rcktec/public_html/guitarbydimitri.com/wp-content/plugins/contus-video-gallery/front/controllers/videohomeController.php:123) in /home2/rcktec/public_html/guitarbydimitri.com/wp-content/plugins/contus-video-gallery/hdflvvideoshare.php on line 1831

    So now I reverted both files back.

    Thank you,

    I downloaded the php files (dropbox links) to my server. YouTube videos are playing now, BUT – is a very, very, very big BUT – initial features are not shown (and are still enabled): Playlist, Playlist Autoplay, Logo, Show Description, Skin Configuration (like Display Zoom, Display Email, Diplay Share, Display Volume, Display Progress Bar etc.), Auto Play, all colors I chosed, etc. and all others from the settings page.
    So how do you resolve these issues or add back features right now or further? They are important part, the base of this plugin.

    OK, one person’s problem solved!but I am still out of commission. and the dropbox folder are no longer there

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Net connection not available in your system’ is closed to new replies.