Support » Plugin: Shortcodes Ultimate » Nested accordions not working properly in v5.0.4

  • Resolved NanoWisdoms

    (@nanowisdoms)


    I have multiple nested accordions that were working fine until v5.0.4. I am currently on WordPress 4.9.6.

    Here’s what used to show up in v5.0.3 when collapsed (perfect):
    2018-06-04_0039

    And expanded with v5.0.3 (perfect):
    2018-06-04_0040

    Here’s what now shows up with v5.0.4 when collapsed (second level short code not processed):
    2018-06-04_0000

    And expanded with v5.0.4 (3rd level accordion doesn’t even appear and short codes appearing):
    2018-06-03_2357

    Here’s my code (which worked fine in v5.0.3 (as above)):
    2018-06-04_0005

    Any suggestions?

    • This topic was modified 1 year, 7 months ago by NanoWisdoms.
    • This topic was modified 1 year, 7 months ago by NanoWisdoms.
    • This topic was modified 1 year, 7 months ago by NanoWisdoms.
    • This topic was modified 1 year, 7 months ago by NanoWisdoms.
Viewing 13 replies - 1 through 13 (of 13 total)
  • Hi @nanowisdoms,

    I’m facing the same issue after updating the plugin to V5.0.4.

    Hi, I had the same problem, and i found this in the documentation:

    [su_spoiler title=”Spoiler title”]
    [_su_spoiler] Content [_/su_spoiler]
    [_su_spoiler] Content [_/su_spoiler]
    [/su_spoiler]

    It worked for me even though it meant to do more work.

    I already do all that (see my code screenshot above) and, as you can see from my output screenshots, even nesting 3 levels worked fine in v5.0.3 (and before). It stopped working in v5.0.4.

    I have the same issue (nested accordions showing codes) since the upgrade.

    What is the fix? where is the documentation you are referring to?

    From what I understand, we don’t need the tag [_su_accordion] anymore.

    [su_accordion]
    [su_spoiler title=”Top level spoiler title (spoiler 1)”]
    [_su_spoiler title=”spoiler 1 – sub-spoiler 1″] Content [_/su_spoiler]
    [_su_spoiler title=”spoiler 1 – sub-spoiler 2″] Content [_/su_spoiler]
    [/su_spoiler]
    [su_spoiler title=”Top level spoiler title (spoiler 2)”]Content[/su_spoiler]
    [/su_accordion]

    Is not work for more that 3 levels since I update from 5.0.3 to 5.0.4
    Somebody have already fixed this bug ??

    I’ve tried everything. I give up !!
    Please, if someone knows how to make a 4 or more level spoiler/accordion structure, write down the code here or, even better, if someone have the 5.0.3 version on .zip file, please share with us. Thank you !!

    Thanks a lot for the older version, mate !! Works sweet !! Cheers !!
    People from SU development: Fix that bug, please !!

    I’m also having a problem with this!

    I have multiple levels of nested accordions and 5.04 broke them just like described above. Reverting to 5.03 using the download at the bottom of https://wordpress.org/plugins/shortcodes-ultimate/advanced/ fixes the problem again.

    Developers, please fix this bug introduced by the changes between 5.03 and 5.04.

    Tip

    Never update plugins as soon as they are released. Invariably they are full of errors or have compatibility issues and the cause of great grief. 5.04 appears to be testament to that. Too many WordPress users always dive in and update right away. Tread with caution is all I can say

    Plugin Author Vladimir

    (@gn_themes)

    Hi,

    sorry for the late reply. I’ve missed this thread.

    The solution described here: https://wordpress.org/support/topic/nested-accordions-still-not-working-properly-in-v5-0-6/#post-10709338

    As I explained in that thread with the “solution”, I’m using the correct syntax, so there should be no need to make any changes to functions.php.

    Look closely at the code above. The syntax is correct. It used to work in v5.0.3 and stopped working in v5.0.4.

    Did you change the syntax from v5.0.3 to v5.0.4?

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Nested accordions not working properly in v5.0.4’ is closed to new replies.