• Resolved dhoch14

    (@dhoch14)


    Hello amigo,

    My site (https://longhaultrekkers.com) was recently migrated to https and thus my social media shares are lost. I’m trying recover my FB shares and I’ve read I need to change the <meta property=”og:url”> to point to my old non-SSL site. I have done this in my header file, however, WPSSO adds the old version to my site.

    So, I have duplicates. The FB Sharing Debugger confirms the following error message:

    Object at URL ‘http://longhaultrekkers.com’ of type ‘website’ is invalid because it specifies multiple ‘og:url’ values: http://longhaultrekkers.com, https://longhaultrekkers.com/.

    This there a way to turn this off? I only see the option in the pro version. Surely I can’t be the only one running into this issue as many sites are being migrated to https.

    Thanks,

    Dave

Viewing 1 replies (of 1 total)
  • Plugin Author JS Morisset

    (@jsmoriss)

    The og:url needs to be https (along with all other URLs in your meta tags) – the share buttons you use must share the old http URL (not the https URL) to retain the counters. If you use the WPSSO SSB extension, for example, you’ll find an option under the SSO > Sharing Buttons settings page to force sharing of http URLs.

    WPSSO should warn you if it finds any duplicates when you edit a post / page. The WPSSO meta tags are better than any other plugin I know, and I would suggest disabling any duplicates from other plugins and/or your theme.

    js.

    • This reply was modified 1 year, 11 months ago by  JS Morisset.
Viewing 1 replies (of 1 total)
  • The topic ‘Needing to override the OG:URL’ is closed to new replies.