WordPress.org

Forums

WP Fastest Cache
[resolved] need to refresh to see cached version message (13 posts)

  1. ChuckMaurice
    Member
    Posted 9 months ago #

    hi,
    i've installed this great plugin as explained but i still have this message
    "<!-- need to refresh to see cached version -->" even after logged out and refreshing my page…

    i am not an expert but i can tell the .htaccess file is 644 permissions (i've checked with my ftp client)

    here is the content of my htaccess file

    # BEGIN WpFastestCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    AddDefaultCharset UTF-8
    RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
    RewriteCond %{REQUEST_URI} !^/wp-login.php
    RewriteCond %{REQUEST_URI} !^/wp-admin
    RewriteCond %{REQUEST_URI} !^/wp-content
    RewriteRule ^(.*)$ http://%1/$1 [R=301,L]
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond /flex/domain/themoodboard.fr/site/www/wp-content/cache/all/$1/index.html -f
    RewriteRule ^(.*) "/wp-content/cache/all/$1/index.html" [L]
    </IfModule>
    <FilesMatch "\.(html|htm)$">
    FileETag None
    <ifModule mod_headers.c>
    Header unset ETag
    Header set Cache-Control "max-age=0, no-cache, no-store, must-revalidate"
    Header set Pragma "no-cache"
    Header set Expires "Mon, 29 Oct 1923 20:30:00 GMT"
    </ifModule>
    </FilesMatch>
    # END WpFastestCache
    # BEGIN GzipWpFastestCache
    <IfModule mod_deflate.c>
    AddOutputFilterByType DEFLATE image/svg+xml
    AddOutputFilterByType DEFLATE text/plain
    AddOutputFilterByType DEFLATE text/html
    AddOutputFilterByType DEFLATE text/xml
    AddOutputFilterByType DEFLATE text/css
    AddOutputFilterByType DEFLATE application/xml
    AddOutputFilterByType DEFLATE application/xhtml+xml
    AddOutputFilterByType DEFLATE application/rss+xml
    AddOutputFilterByType DEFLATE application/javascript
    AddOutputFilterByType DEFLATE application/x-javascript
    AddOutputFilterByType DEFLATE application/x-font-ttf
    AddOutputFilterByType DEFLATE application/vnd.ms-fontobject
    AddOutputFilterByType DEFLATE font/opentype font/ttf font/eot font/otf
    </IfModule>
    # END GzipWpFastestCache
    # BEGIN LBCWpFastestCache
    <FilesMatch "\.(ico|pdf|flv|jpg|jpeg|png|gif|js|css|swf|x-html|css|xml|js|woff|ttf|svg|eot)(\.gz)?$">
    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresDefault A0
    ExpiresByType image/gif A2592000
    ExpiresByType image/png A2592000
    ExpiresByType image/jpg A2592000
    ExpiresByType image/jpeg A2592000
    ExpiresByType image/ico A2592000
    ExpiresByType text/css A2592000
    ExpiresByType text/javascript A2592000
    ExpiresByType application/javascript A2592000
    </IfModule>
    <IfModule mod_headers.c>
    Header set Expires "max-age=2592000, public"
    Header unset ETag
    Header set Connection keep-alive
    </IfModule>
    FileETag None
    </FilesMatch>
    # END LBCWpFastestCache

    i've checked all the checkboxes of the extension
    the site address is http://themoodboard.fr/

    thanks in advance for your help,

    kind regards,

    Chuck

    https://wordpress.org/plugins/wp-fastest-cache/

  2. Emre Vona
    Member
    Plugin Author

    Posted 9 months ago #

    can you tell me your url please?

  3. ChuckMaurice
    Member
    Posted 9 months ago #

    hi,

    thanks for your reply, my url is http://themoodboard.fr/

    kind regards,

  4. ChuckMaurice
    Member
    Posted 9 months ago #

    hi,
    do you have time to have a look to my issue?
    thx,

  5. Emre Vona
    Member
    Plugin Author

    Posted 9 months ago #

    of course but your site does not work properly

    Warning: include(after-the-deadline/config-options.php): failed to open stream: No such file or directory in /flex/domain/themoodboard.fr/site/www/wp-content/plugins/jetpack/modules/after-the-deadline.php on line 27 Warning: include(): Failed opening 'after-the-deadline/config-options.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /flex/domain/themoodboard.fr/site/www/wp-content/plugins/jetpack/modules/after-the-deadline.php on line 27

  6. ChuckMaurice
    Member
    Posted 9 months ago #

    hi,
    i know! but sometimes it runs properly. if it shows errors you do some refresh/reload page until it displays properly.
    it's for this reason that i want to use your plugin to avoid too much server requests…
    kind regards,

  7. Emre Vona
    Member
    Plugin Author

    Posted 9 months ago #

    /wp-content/cache/all is empty?

  8. ChuckMaurice
    Member
    Posted 9 months ago #

    no!
    there are folder:
    all (with elements inside)
    config (empty)
    index.html
    pages_enchanced (with elements inside)
    tmp (empty)
    wpfc-minified (with elements inside)

  9. Emre Vona
    Member
    Plugin Author

    Posted 9 months ago #

    it means that .htaccess problem. Can you write me an email please?

  10. ChuckMaurice
    Member
    Posted 9 months ago #

    hi,

    of course chuckmaurice@free.fr

    many thanks for your help

  11. Emre Vona
    Member
    Plugin Author

    Posted 9 months ago #

    The bug has been fixed

  12. erc_erd
    Member
    Posted 7 months ago #

    Emre bey bende de aynı sorun var bu neden kaynaklanıyor lutfen cevap

  13. Emre Vona
    Member
    Plugin Author

    Posted 7 months ago #

    fastestcache@gmail.com adresine mail atabilir misiniz?

Reply

You must log in to post.

About this Plugin

About this Topic