• Resolved lellojello

    (@lellojello)


    This seems to be a common problem but I don’t know how to fix it.

    Site Kit by Google: Looks like the URL of your site has changed. In order to continue using Site Kit, you’ll need to reconnect, so that your plugin settings are updated with the new URL. Reconnect

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support James Osborne

    (@jamesosborne)

    Hi @lellojello,

    Thanks for reaching out. From inspecting your site I can see that both the secure (https) and the non secure (http) versions of your site are accessible. In addition, from checking your public REST endpoints it looks like you may have mismatching URLs defined within your WordPress configurations, one with http and the other https.

    In such cases it’s not unexpected to become disconnected, as Site Kit uses only one version of your site to connect with and display information from. If you, as a site administrator, happen to access the non connected version, the plugin will recognize a site URL change.

    Luckily there is an easy solution to this. Firstly you can define both URLs as fully secure (https), from your WordPress general settings screen (Settings > General). As your website has a valid security certificate this will also ensure your traffic is fully https. Note that if Site Kit is currently connected to the http version of your site, you may be asked to reconnect once more, at which point you should remain connected.

    You may then also wish to ensure all non secure traffic to your site is always secure you can use a plugin, or setup a http > https redirect at host level.

    Let me know if you need any assistance with the above. I’m also happy to check that your website is only accessibly via https once you make the changes above.

    Plugin Support James Osborne

    (@jamesosborne)

    @lellojello Just following up with you to check whether you’ve had an opportunity to review the above suggestions?

    From reviewing your public REST endpoints at present it looks like both site references include your secure (https) status. With that please let me know if you’re being asked to re-connect Site Kit as you were previously, with mismatching URLs.

    Thread Starter lellojello

    (@lellojello)

    Hi James,
    It only seemed to reset ever 24 hours or so, so I did do what you suggested six days ago, and then promptly got a blinding migraine for 5 days and couldn’t check to see if it had worked. Now that I’m able to look at a computer again, it seems to have done the trick.
    I am so appreciative of your help, because I was absolutely at my wit’s end <3

    Plugin Support James Osborne

    (@jamesosborne)

    No problem for the delay in responding, happy to hear that both you’re no longer suffering from migraine. Happy also to hear you’re no longer being asked to re-connect to Site Kit frequently!

    If you run into any further issues be sure to reach out, and best of luck with your Site Kit enabled site.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.