WordPress.org

Support

Need to disable classes

  • I added the plugin to my website http://www.leraland.com because I love the hover ability. I have two questions… I apologize in advance if they’re just user-error.

    1) I have the Image Selector set to “img” because when I set it to “div.jpibfi_container img” nothing showed the highlight or the Pinterest pin. I know that creates the issue that EVERYTHING shows the pin. I only want it showing up on post images on the main blog page (my homepage) and the interior individual posts. I would like to disable it elsewhere (sidebar, header, footer).

    2) I created a custom pin, but it doesn’t seem to show up. The image highlights when it is hovered over, but the actual button doesn’t show. I input the url & height/width. It was uploaded in the folder http://www.leraland.com/wp-content/plugins/jquery-pin-it-button-for-images/images/Leraland_PinIt-01.png

    What am I doing wrong in this case? **ALSO – is there a way to have it show up on the bottom right corner of the image, instead of the top left?

    Thanks so much!
    Lera

    http://wordpress.org/extend/plugins/jquery-pin-it-button-for-images/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Marcin Skrzypiec

    @mrsztuczkens

    Hi,

    #1: Try using div.page-content as the selector. It should work fine. There’s a small bug in the plugin with the selector (it can be noticed only on a very few themes). I’ll fix it in the next version of the plugin.

    #2: I believe you’ve put www.leraland.com/wp-content/plugins/jquery-pin-it-button-for-images/images/Leraland_PinIt-01.png instead of http://www.leraland.com/wp-content/plugins/jquery-pin-it-button-for-images/images/Leraland_PinIt-01.png as the custom image url. Make sure there’s the http:// part at the beginning of the url.

    #3: About putting the button on the bottom right corner of the image: the plugin doesn’t have that option right now, but I’ll consider adding it in one of the next versions of the plugin. I believe it’ll be pretty useful. For now you can make your own workaround using CSS.

    Please let me know if you’ve been able to resolve issues #1 and #2 😉

    Hello!

    Thanks so much for the response. I’ve updated the selector to “div.page-content” and it went back to none of the images having the pin – including the imagery in the posts. The only image the has anything happen s the “featured image” > it doesn’t have the pin, but it does highlight when hovered over. The image that is simply in the content of the post (second one down) on the homepage doesn’t do anything.

    I updated the url to point to my custom button as you mentioned, but it still isn’t showing up…

    Maybe I’m doing something wrong?:)
    Thanks so much!
    Lera

    Plugin Author Marcin Skrzypiec

    @mrsztuczkens

    Hi again, the selector should be div.page-content img, sorry for my silly mistake. Hope it’ll help.

    Unfortunately, this selector will also “catch” images to share on Facebook, etc. I will check if there’s a good way to fix this issue tomorrow.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Need to disable classes’ is closed to new replies.
Skip to toolbar