Support » Plugin: Ajax Search Lite » Need to add proper labeling for WCAG

  • digdug5

    (@digdug5)


    Using an accessibility checker they often don’t totally factor in aria settings, for instance using https://achecker.ca/checker/ I get the following labeling errors. Is there a way to correct this so i’m not having hack the plugin itself? Thank you…

    input element, type of “text”, missing an associated label.
    Repair: Add a label element that surrounds the control’s label. Set the for attribute on the label element to the same value as the id attribute of the control. And/or add a title attribute to the input element. And/or create a label element that contains the input element.
    <input aria-label=’Autocomplete input, do not use this’ type=’text’ class=’autocomplete’ name=’phras …
    ______________________________________________

    Repair: Add text to the input element’s associated label that describes the purpose or function of the control.
    <input aria-label=’Autocomplete input, do not use this’ type=’text’ class=’autocomplete’ name=’phras …
    ______________________________________________
    Label text is empty.
    Repair: Add text to the label element.
    <input aria-label=’Search input’ type=’search’ class=’orig’ name=’phrase’ placeholder=’Search here.. …
    <input aria-label=’Autocomplete input, do not use this’ type=’text’ class=’autocomplete’ name=’phras …

    • This topic was modified 1 year ago by .
Viewing 1 replies (of 1 total)
  • Plugin Author wpdreams

    (@wpdreams)

    Hi,

    Unfortunately that would break the plugin functionality as well as the layout. The label elements are omitted on purpose, as they would be completely empty, and the aria-* element are used instead.
    The aria-* attributes are considered correct by actual accessibility readers. We use the WAVE tool to check for these errors, that facors in some accessibility tags, although not all of them.

    Best,
    Ernest M.

Viewing 1 replies (of 1 total)
  • The topic ‘Need to add proper labeling for WCAG’ is closed to new replies.