Support » Plugin: Rich Reviews » Need the Review Form as well as the Reviews for that Post on the post page

  • Resolved archlogan

    (@archlogan)


    Hi,

    This is what im trying to achieve I want a Review Form as well as the Reviews for that post on the same post page and I want to do this via Templates as there are too many posts already on my blog.

    I have done this which shows the Review Form and it works fine but im having issues displaying the Reviews on the same page…

    In the Single Post Template I added this

    <div>
    <?php echo do_shortcode('[RICH_REVIEWS_FORM]'); ?>
    </div>

    Which displays the form correctly and I also tried making a test review and approved it and it shows it in the backend with the Post ID which I think is correct..now on the same page i want to display the reviews what members have put I tried using these codes but the results are blank any help on this would be appreciated..

    <div>
    <?php echo do_shortcode('[RICH_REVIEWS_SHOW]'); ?>
    </div>

    Result : No Output

    <div>
    <?php echo do_shortcode('[RICH_REVIEWS_SHOW category="post"]'); ?>
    </div>

    Result : No Output

    <div>
    <?php echo do_shortcode('[RICH_REVIEWS_SHOW category="page"]'); ?>
    </div>

    Result : No Output

    Could you please help me display the Reviews please?

    Note : When I use the Snippet Shortcode it shows the Review Count.

    http://wordpress.org/plugins/rich-reviews/

Viewing 15 replies - 1 through 15 (of 19 total)
  • Did I miss something?? Guys I need help please

    Did you get this worked out? If not can you post a link to your page?

    The way you’re adding the shortcode to your template looks correct to me, but I’d be glad to take a look at your page and see if I can tell what might be going on.

    The latest update is not working for me as well.
    Version 1.4.1 used to work for me when using [RICH_REVIEWS_SHOW] on a single post but after the update, it’s not showing anything at all.
    Thanks.

    Found that the issue is due to the ‘order by id’ codes in the fp_shortcode_reviews_show function. The reviews are showing on my sidebar widget again after I removed that piece of code.
    Please kindly look into this issue.

    On a side note, it would be great if you could add a link to the post when we place RICH_REVIEWS_SHOW in the sidebar widget. Thanks.

    @trisham its still not working here is the Page I have the Form and also the Show Reviews Snippet

    http://bit.ly/16CfBXp (Shorted Link)

    TrishaM

    (@trisham)

    @archlogan…..is the rich-reviews.css stylesheet you’re using unmodified from what comes with the plugin? I noticed that your styles for the element that shows the reviews (.testimonial_group) is different from mine…..specifically it’s calling some box-model declarations…..not that that’s a bad thing, but I wonder if the difference in styles is accounting for why your reviews aren’t showing…..

    I am using version 1.4 of Rich Reviews, which I cannot update because I’ve hacked it up too much to make it do what I needed it to……so possibly that’s why your stylesheet is different, but you might try commenting out the box-model stuff to see if that makes any difference.

    Also, while it >>shouldn’t<< make any difference, there might be a conflict with the post ratings plugin you’re also using….you could try deactivating that plugin to see if that makes any difference.

    jordanlovato92

    (@jordanlovato92)

    Hey guys,

    I just did some debugging for this plugin and the main SQL queries that grabs all the saved reviews was getting sent slightly incorrectly.

    I’ve fixed that line of code and everything seems to be working alright. I’ve repackaged the plugin with that fix, hopefully it work for ya’ll too!

    https://dl.dropboxusercontent.com/u/64974305/rich-reviews-quickfix.zip

    EDIT: Note that the rich-reviews/rich-reviews.php file is the only one that’s changed, and futhermore, the fp_shortcode_reviews_show function is the only function that’s change within that file.

    archlogan

    (@archlogan)

    @trisha I tried disabling the Rating plugin and that too did not help…could u please explain what is that Box-Model thing u found? as I could not find that…

    archlogan

    (@archlogan)

    @jordan can u specify which files have u changed and what did u change?

    TrishaM

    (@trisham)

    @archlogan – I’d suggest trying @jordanlovato92‘s fix before you look at anything else.

    The box-model stuff I was referring to is in the CSS files that comes with the plugin – I don’t recommend changing that directly (because any changes you make would get overwritten by updates to the plugin), if you want to change any of the styling you should add new styles with the same names to your own stylesheet.

    HOWEVER, that said, it’s unlikely that the box-model styles is the culprit…..I was simply looking for differences in your version and mine, since mine is working fine.

    I hope his fix works for you! If it does be SURE to post back here and mark your question as “resolved”

    jordanlovato92

    (@jordanlovato92)

    @archlogan check my edit, good sir. It’s really just changing the query such that the limit statement come last.

    Jeremen

    (@jeremen)

    I have the same problem

    Jeremen

    (@jeremen)

    RICH_REVIEWS_SHOW_ALL – this shortcode is work.

    toby04

    (@toby04)

    Thank you Jordan! That worked perfectly! But now it wants an update, is that going to break it again?

    jordanlovato92

    (@jordanlovato92)

    Yep! But as far as I’m aware, the patch just adds a French translation to the admin menus, so unless you’re extremely smelly…

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Need the Review Form as well as the Reviews for that Post on the post page’ is closed to new replies.