WordPress.org

Support

Support » Themes and Templates » Need some help

Need some help

  • My site uses basic PHP (http://starlit-seas.net). I would like to add the header and footer files I already use to my blog. Is there any way I can do that? I’m not very experianced with PHP (I learned it from a tutorial at http://second-breakfast.net/) at all. My header and footer files have the extensions .txt instead of .inc, as I have seen it elsewhere. Will this be a problem?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Make a php file called footer.php and put the footer information (html, php code, etc.) in this file. Save it and then include it into the pages that need the footer.

    You may want to look into the php include function:

    http://us3.php.net/include/

    Moderator James Huff

    @macmanx

    All you really need for WP to function, if you want to use your own design, is the Loop. The Loop is the php code that displays WP’s posts.
    http://codex.wordpress.org/The_Loop

    Here are some WP-specific design sources if you want to expand on that as well:
    http://codex.wordpress.org/Template_Tags
    http://codex.wordpress.org/CSS_Selectors
    http://codex.wordpress.org/Blog_Design_and_Layout

    I used the Loop coding for WordPress 1.2, but it’s not showing up on my page. http://starlit-seas.net/main.php Did I do something wrong? =\

    Don’t look for it on your “generated” HTML page, Lalaith. It is in your index.php page before it is turned into HTML.

    You can see it either through WP Admin in the TEMPLATES section or by copying the file to your hard drive via FTP (or looking at the one you should have had on your drive when you installed WP).

    The loop begins with <?php if ($posts) : foreach ($posts as $post)… if memory serves me right. Check the link above for specifics.

    OK, I’m obviously doing something very wrong. Fistly, I’m trying to put a background image on index.php, but the image won’t show up. Secondly, I use DIVs on my site but they don’t seem to be working. The navigation and a few other things should be on the left, and the blog/content should be on the right, but they’re “on top of each other” (so to speak) on the right. Can anyone help me? I’m sorry to be such a bother…

    TechGnome

    @techgnome

    Moderator

    Looks like you used more than just the loop…. at least in the iframe section. If you don’t want the navigatio nstuff inside the iframe, you need to remove it. The only thing left in it should be just the loop stuff (oh and the include that’s at the top fo wp-blog-header.php, keep that as it’s importaint.

    Tg

    OK, I’ve pretty much got it under control (finally). Thanks for all of your help, everyone. =)

    I just have one question: how do edit the text of the actual blog? I went all over wp-layout.css, but I couldn’t find the right section. =\

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Need some help’ is closed to new replies.
Skip to toolbar