Support » Plugin: Sucuri Security - Auditing, Malware Scanner and Security Hardening » Need Resolution: 504 Gateway Timeout from wp-admin login

  • Resolved thenewmcq

    (@thenewmcq)


    By process of elimination, I have determined that the Sucuri WordPress plugin is the cause of 504 Gateway Timeouts when I try signing in to my wp-admin.php. I am unsure what within the plugin is specifically causing this and I am seeking assistance. I went ahead and “Reset Everything” within the plugin so it would be back to defaults but the issue remains.

    I can eventually get signed in but it will typically 504 five or more times before I get in.

    Any suggestions?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi

    I’ve been having the same issue for a few weeks and finally today managed to isolate Sucuri as the cause (deleted all plugins and reactivated them one at a time).

    The error logs were showing repeated entries of “End of script output before headers: php56-cgi”

    I’ve deleted sucuri for now and the problem has gone, but I would like to re-install if possible. I do use Sucuri on my other sites without issue so not sure what’s going on…

    Plugin Author Daniel Cid

    (@ddsucurinet)

    That’s very interesting. The plugin should not cause the 504’s and we were never able to duplicate this problem.

    Would you be open to let us troubleshoot it on your environment? If you don’t mind emailing me at dcid@sucuri.net, I will get you the steps to help us with the troubleshooting.

    thanks,

    Thanks Daniel. I sent you an email.

    Hello

    I have the same issue today, and disabling Sucuri (by renaming the plugin folder in FTP) makes it possible to login. But I would prefer to keep using Sucuri.

    @ddsucurinet @thenewmcq, since the topic is marked as resolved, would you care to elaborate how you fixed it ? It could be useful to other users as this page ranks #1 for ‘504 Gateway Time-out wordpress login’.

    Hi @kalshyre. Hopefully Sucuri can chime in to help you. I gave them access to my site for several days (longer than they asked for) and they never resolved the issue. My solution ended up being that I stopped using Sucuri.

    Ok, that’s good to know. Thanks !

    @thenewmcq, it seems that the update Sucuri released this morning (1.8.7) solved the problem.

    It’s good, because there was also a gateway timeout on front-end attachment upload (which meant for us that Sucuri had to be disabled full time, not only to login).

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Need Resolution: 504 Gateway Timeout from wp-admin login’ is closed to new replies.