Support » Plugin: WooCommerce PDF Invoices & Packing Slips » Need (inc GST) to display and NOT (inc Tax) on Woocommerce

  • Resolved kristinubute

    (@kristinubute)


    Following on from previous ticket:

    https://wordpress.org/support/topic/override-tax-text/

    I am having similar issue to this ticket.

    I have got all settings as per previous ticket:

    I have added the filter:
    add_filter( ‘gettext’, function( $translation, $text, $domain ) {
    if ( $domain == ‘woocommerce’ ) {
    if ( $text == ‘(includes %s)’ ) { $translation = ‘(inc. %s)’; }
    }
    return $translation;
    }, 10, 3 );

    All Woocommerce settings are:
    Plugin AuthorEwout (@pomegranate)
    1 year, 5 months ago
    I can see how these different strings are confusing, but the plugin is actually honouring the WooCommerce settings and tax name, it’s just that they are for different parts of the order details/totals and the “Display tax totals” setting also plays an important role here. I’ll illustrate with a few screenshots that will hopefully clear up the confusion.

    SO i have:

    – added in the functions.php above change
    – My Country shipping is ONLY Australia and based in Australia
    – I have set to Itemised and apparently it will show “GST” everywhere which mine doesn’t.

    ONLY the total displays “Inc GST” and Sub-Total and Shipping shows “Inc Tax” which needs to show the wording “Inc GST”

    Plugin AuthorEwout (@pomegranate) stated:
    If you set it to “Itemized” it will show “GST” everywhere (including cart, checkout & emails). This is because if you have multiple different tax rates+names, WooCommerce wouldn’t have any base for choosing the appropriate tax name for the “Single total”, so it uses the generic term “tax” instead. Set it to “Itemized” and it will output the tax amounts per tax rate with the name you have set in WooCommerce.

    So I am not sure what else to check ?

    If someone could advise urgently would be great.

    Regards
    Kristin

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.