WordPress.org

Forums

Need help with permalinks (9 posts)

  1. mlyman
    Member
    Posted 10 years ago #

    Hi all,

    I'm a wordpress newbie and in over my head, so please be gentle! I've got wordpress installed and am having trouble getting permalinks working properly.
    In the permalink settings under options I entered-
    Structure: /%year%/%monthnum%/%day%/%postname%/

    Under Category base it says:
    If your .htaccess was writable we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. I then pasted that content into a .htaccess file and uploaded it. It totally crashed the site. I then deleted it and am not sure what to do now.

    I verified the shared server is running Apache and has mod_rewrite enabled. I'm us WP 1.5.
    The blog is at http://flashpointstudios.com/homefixated/

    If you click on a story link, it uses the right structure but doesn't actually pull up the link.

    How do I get permalinks working at this point? Do I need to upload a new .htaccess file? If so, do I need to set specific permissions and paste the same content suggested in the permalink options page in admin?

    Any help would be great appreciated.

  2. carthik
    Member
    Posted 10 years ago #

    Yes, if you do not already have a .htaccess file, you have to upload a new blank .htaccess file.

    You can set the permissions for the .htaccess file so that WP can write to it automatically, which will save you the trouble of manually editing the file.

    Try permissions 600, 644, 666, 777 in that order. The last two are not too secure, just so you know. I personally like to change to 777, let WP do it's updating, and then switch back to 644. That's easy and it works :)

  3. freewanderer
    Member
    Posted 10 years ago #

    You do need a .htaccess file to have permalinks. If there is no .htaccess at the moment, make sure you copy ALL content from the admin (Press Ctrl+A to select all, and Ctrl+C to copy) and paste it onto a plain text document, save, and upload.

    If there is a .htaccess, append the content from admin to it.

  4. mlyman
    Member
    Posted 10 years ago #

    Hi Carthik and Freewanderer,

    Thanks for the help. Tried uploading a new .htaccess (with 777 temporarily) and I'm now getting an internal server error when trying to access the site. Any ideas?

  5. vkaryl
    Member
    Posted 10 years ago #

    Make sure you're not putting the .htaccess file in the wrong folder....

  6. mlyman
    Member
    Posted 10 years ago #

    Hi vkaryl,

    I'm putting it in the folder that index.php, wp-admin, wp-content, etc. all reside in. Is that correct?

  7. mlyman
    Member
    Posted 10 years ago #

    OK, I followed carthick's steps, one by one, and they all lead me to the same server error (actually one of the permissions led me to an error that said forbidden).

    Whenever I delete the .htaccess file, the site comes back up, but the permalinks don't function. When I upload the .htaccess file (no matter what permissions, I then get the "Internal Server Error" again for any page I try to open up (including admin).

    When I've uploaded the new .htaccess file, I've pasted the exact content I'm told to paste in from the admin permalink options area.

    Any ideas on what I might be doing wrong? I'd be greatly appreciative for your help in getting my site and permalinks working right. Thanks. . .

    Also, I don't understand why wordpress isn't doing this automatically. Under the admin options permalinks section it says it should take care of the .htaccess file automatically, but it can't since .htaccess is not write-able. I don't understand this since right now I've got a blank .htaccess file loaded with permissions set to 666. My site pulls up, but the permalinks don't function. If I go to paste in the content on the permalink options page it just crashes my site with the Internal server error again.

  8. jimhobbs
    Member
    Posted 10 years ago #

    I have exactly the same problem mlyman
    I posted my problem on an earlier thread here:
    http://wordpress.org/support/topic.php?id=28990

    I've tried several different things recommended in the above thread but still I'm stuck with the same annoying problem. Wish I understood more behind the workings of php etc, but quite frankly it all baffles me! :(

  9. mlyman
    Member
    Posted 10 years ago #

    I figured out my issue! Turns out the Blog address (URI) under general options in the WordPress admin was set to the wrong address. Correcting it to match the WordPress Address (URI) (and the correct address for the blog) fixed the issue!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.