Support » Plugins » Need help with contact form 7

Viewing 15 replies - 1 through 15 (of 17 total)
  • This
    [contact-form 1 "Contact form 1"]
    is supposed to be pasted into the WordPress editor when you are editing the Contact page. Update and save.

    When the contact page is displayed the plugin will replace
    [contact-form 1 "Contact form 1"]
    with the form you created.

    i followed the steps on the contact-form site (well it redirected to wordpress) and it didn’t mention wordpress editor but a tab called “Pages” and I copied the code

    You have to paste that into the editor box when you are editing the page called Contact. (It could be any page or any post but you want it on your contact page).

    Its that simple. If you haven’t done that then do it and it will work.

    that’s what I did. I made a page called “Contact” and pasted the code in and there’s nothing when I click on the link.

    the “Contact” page is linked to an existing page I have, could that be the problem? Should I make the link to an index.html that doesn’t index?

    What do you mean by “click on the link”? What link?

    Are you clicking a Nav link to call up the contact page and the page is coming up empty, or are you clicking a link on the contact page that is supposed to display the form?

    You need to paste the form code onto a WordPress page that displays when you call up its URL. No redirection, no forwarding to any other page.

    For testing, create a new page called Test and paste the Contact Form 7 code on that page. Then view the page called Test.

    Ok I created a page called “Test” and pasted the code. It creates a permalink and when I click on view page I get the 404 error.

    Then you have a problem with the way your permalinks are set up.

    Go to Dashboard Settings / permalinks. Take note of what your permalinks are set to.

    Reset them to the first option, the default, and save your changes.

    Then change the permalinks back to what they were before you changed them to the first option and save them again.

    The reason you are doing this is this combination makes WordPress reset all its redirection code. Most likely that is why you had a 404. Then try calling up the test page again.

    No dice…clicking on “test” now takes me to the url “” and on screen its my websites main page.

    that means you did not successfully reset the permalinks back to the way they were before.

    set them to how they were before you set them to the default.

    Refresh the permalinks page and take a look – ten to one it is still set to default.

    I simply don’t understand this stuff at all. Thanks for all the help but I’m just too clueless to do this.

    I put under custom structure “/ %postname%” cause I saw something like that on the wordpress site when looking at permalinks…I don’t know cause that looks so wrong.

    there is not supposed to be a space between the slash and the rest of it


    you can copy and paste it from here into the custom permalinks field



    Forum Moderator

    Try reading Using_Permalinks.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Need help with contact form 7’ is closed to new replies.