Support » Themes and Templates » Need help upgrading theme to 2.3.

  • I just upgraded to 2.3 and now my index page is hosed. All the other ‘pages’ and ‘post’ pages work completely fine. The index page, however, does not load. Is there some kind of changelog I can look at so i can update my index page?

    I use the LivingOS PSI theme if that helps. Any help is appreciated.

    Thanks,
    Ryan

Viewing 3 replies - 1 through 3 (of 3 total)
  • What theme are you using?

    Did you make sure it is compatible with 2.3?
    http://codex.wordpress.org/Themes/Theme_Compatibility/2.3

    Might need to give us a link to see the problem.

    It’s not listed compatable, but the only page that doesn’t work is the index page. I really like the theme. I just discovered that this is the issue:


    <ul class="no-list-style">
    <?php
    global $post;
    $myposts = get_posts('numberposts=2');
    foreach($myposts as $post) :
    setup_postdata($post);
    ?>

  • "><?php the_title(); ?> -<?php the_time('m/j/y'); ?> at <?php the_time(g:i a); ?> <?php the_excerpt(); ?>
  • <?php endforeach; ?>

    All I’m looking to do is have a list with the two latest posts. Here’s a link in case we need to look at something in the future:

    http://ryanandmonica.thefrengs.com/blog/

    (i know i know, but its a wedding site 😉

    Thanks,
    Ryan

Apparently you can have an a href inside of code and it tries to process. Hopefully this works. Here’s the last part of the code.

<li><a href="<?php the_permalink(); ?>"><?php the_title(); ?></a> -<em><?php the_time('m/j/y'); ?> at <?php the_time(g:i a); ?></em> <?php the_excerpt(); ?></li>
 <?php endforeach; ?>
 </ul>
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Need help upgrading theme to 2.3.’ is closed to new replies.