Support » Everything else WordPress » Need help in sending emails

  • amitkulkarni2094

    (@amitkulkarni2094)


    Hello,

    I am new to wordpress entirely and learning it. I recently moved a client’s website from wpengine to google cloud platform. The issue is after migrating the website, contact form 7 started showing error ‘Failed to send your message. Please try later or contact the administrator by another method.’ and client stopped receiving any new contact form submission emails.

    I searched a lot and found that WPSMTP plugin can be useful (This plugin was already there but it was deactivated, I activated it and found that it has only domain email in ‘from email’ option with default PHP selected as SMTP settings) and used gmail smtp, created a new gmail ID and then email function started working with no errors.

    Now ! Client said that he wants to use his website domain email id to receive contact form submission emails and does not want a new gmail ID. He uses Office365 and logs in there with the domain email id. I asked him for SMTP server settings and email id password to put that into wpsmtp plugin. He told me that previous developer who initially created the website for him never asked for any SMTP server settings or email id and password to make emails work.

    I only have his domain email id right now.

    Similarly, He has resolved his other website’s similar email issue via another third party who used formidable forms instead of contact 7 forms. And he did not use WPSMTP plugin nor he used PHP email function. Client receives emails from that website but still error is displayed (‘Failed to send your message. Please try later or contact the administrator by another method’) there as well.

    Is there any way to make his emails work with only contact form 7 or formidable forms.
    Am I wrong here to ask SMTP settings and email id password to setup wpsmtp plugin for him?

    Please help.
    Thank you !
    🙂

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.