WordPress.org

Forums

Need Help getting Featured Slider ot work (6 posts)

  1. andrecampbell
    Member
    Posted 2 years ago #

    Hi,

    I got the Pioneer WordPress theme. And I need help getting the main page featured slider to work. I was able to get the post to show, however, the images for the post dont show. Below is a snippet of the code used in the part used for the slider.

    Thanks, you help is greatly appreciated.

    The Pioneer theme can seen here.
    http://bodegazine.com/free-pioneer-magazine-theme/

    <!-- BEGIN featured -->
    <div id="featured">
    	<!-- begin slider -->
    	<div class="slider">
    		<?php
    		$tmp_query = $wp_query; $count = 0;
    		query_posts('showposts=3&cat=' . get_cat_ID(dp_settings('featured')));
    		if (have_posts()) :
    		while (have_posts()) : the_post(); $count++;
    		?>
    		<div id="slide<?php echo $count; ?>" class="item">
    			<a class="featuredimg" href="<?php the_permalink(); ?>"><?php dp_attachment_image($post->ID, 'full', 'alt="' . $post->post_title . '"'); ?></a>
    			<div class="text">
    				<h2><a href="<?php the_permalink(); ?>"><?php the_title(); ?></a></h2>
    				<p><?php echo dp_clean($post->post_content, 180); ?> [...]</p>
    			</div>
    		</div>
    		<?php
    		endwhile;
    		endif;
    		$wp_query = $tmp_query;
    		?>
    		<ul>
    			<?php
    			$tmp_query = $wp_query; $count = 0;
    			query_posts('showposts=3&cat=' . get_cat_ID(dp_settings('featured')));
    			if (have_posts()) :
    			while (have_posts()) : the_post(); $count++;
    			?>
    			<li<?php if ($count==1) echo ' class="active"'; ?> id="thumb<?php echo $count; ?>">
    				<a href="#"><?php dp_attachment_image($post->ID, 'thumbnail', 'alt="' . $post->post_title . '"'); ?></a>
    				<a href="#" class="title"><?php the_title(); ?></a>
    				<p><?php echo dp_clean($post->post_content, 80); ?> [...]</p>
    			</li>
    			<?php
    			endwhile;
    			endif;
    			$wp_query = $tmp_query;
    			?>
    		</ul>
    		<div class="hover"></div>
    	</div>
    	<!-- end slider -->
    </div>
    <!-- END featured -->
  2. andrecampbell
    Member
    Posted 2 years ago #

    Disregard. Solved.

  3. bonty
    Member
    Posted 2 years ago #

    How did you get the slider to work? I still have this problem and cannot seem to find a solution.

  4. cbrunelli
    Member
    Posted 2 years ago #

    Hello andrecampbell! How do you solve your problem? Could you help me? Thank you my friend!

  5. esmi
    Forum Moderator
    Posted 2 years ago #

    As per the Forum Welcome, please post your own topic. Posting in an existing topic prevents us from being able to track issues by topic. Added to which, your problem - despite any similarity in symptoms - is likely to be completely different.

  6. Andrew
    Nuh uh moderator
    Posted 2 years ago #

    Consider creating your own thread on the issue, as you're not contributing towards the original poster.

Topic Closed

This topic has been closed to new replies.

About this Topic