Support » Plugins » Hacks » Need Help Diagnosing Permalink Problem Reports

  • I’m having trouble with reports of 404 errors from some but not all users of an event management plugin I created that uses WP3 custom post types. It works fine on my system, and those of some other happy customers, but the people who are having trouble report they get page not found when they try to click on a permalink associated with the post type.

    I would appreciate any suggestions on how to track down the problem. The custom post type is registered as ‘event’ so the permalink structure is /event/%event%

    At one point I, thought the url parsing routine might be getting confused between that and a page on one of the problems sites that was /events/ — based on another post I saw that discussed these sorts of problems. Someone said the parser could be confused if a similar slug was used in the category hierarchy. But I tried changing the post type slug to ‘rsvp-event’ and that didn’t seem to make a difference. I had one of the people who was having trouble install it on her site.

    Below, I’ve included the custom post type setup code and a data dump of the rewrite object it creates.

    The plugin in question is this:

    http://wordpress.org/extend/plugins/rsvpmaker/

    The custom post type setup code looks like this:

    [Code moderated as per the Forum Rules. Please use the pastebin]

    BTW, I had one of the people who was reporting problems do the same data dump of the rewrite object, and it looked essentially identical. So it’s not that flush rewrite hasn’t run, apparently. She is running WP3.0

Viewing 4 replies - 1 through 4 (of 4 total)
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Need Help Diagnosing Permalink Problem Reports’ is closed to new replies.