Support » Plugin: Relevanssi - A Better Search » Need help!

  • Resolved seyntjim

    (@seyntjim)


    Hello,

    I’ve been using your plugin for a while and I am impressed the way it handle the search function on my site compared to default wordpress search. But there is one thing I can’t make it to work. Here’s the example so I can explain it more clearly.

    Let’s say I have 4 posts with these titles:

    1. One more try
    2. One more thing
    3. One last cry
    4. No more tears

    Please note that I am only using the title search. I have disabled the content, comment, custom field search, etc.

    If I search the words “One more”, all 4 posts displayed in search results. What I want to do is the result should be only the post number 1 and 2. Is it possible? Thank you and sorry for my English.

    https://wordpress.org/plugins/relevanssi/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Mikko Saari

    (@msaari)

    This search doesn’t work as expected as both “one” and “more” are stopwords and thus not indexed by Relevanssi. If you make sure the words are not on the stopword list (and then rebuild the index) and set the default operator to “AND”, the search should work the way you expect it to.

    Thank you! I’ll try it then get back here. 🙂

    Thank you Sir Mikko. It worked! Can I ask one last thing? I don’t really understand how to use the Custom Field to Index feature. It says “A comma-separated list of custom fields to include in the index. Set to ‘visible’ to index all visible custom fields and to ‘all’ to index all custom fields, also those starting with a ‘_’ character.”

    How do I set it to all or visible? I can’t see any options there. I have a custom field with named “aka”.

    For Ex:

    Post Title: John Doe
    custom field: aka
    custom field value: The Destroyer

    What I want to happen is when someone search for “The Destroyer”, John Doe will appear in search result.

    Thanks in advance!

    Plugin Author Mikko Saari

    (@msaari)

    You write “all” or “visible” to the setting text field. If your custom field is named “aka”, then you write “aka” (without the quotes) in the setting text field. Then just rebuild the index.

    Thank you so much! I forgot to rebuild the index. 😀 I’m going to buy the premium plugin when I have enough money, that’s a promise. 😀

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Need help!’ is closed to new replies.