Support » Plugin: Duplicator - WordPress Migration Plugin » Need Elementor compatibility

  • Resolved bkjproductions

    (@bkjproductions)


    I suspect that this does not work well with Elementor. We’ve had three sites so far where we had built packages and went to install on a new server, and it failed to install completely; most of the data was there but a few key fields didn’t make it or something. There is probably something wrong with the “packed data.” By this I mean the data is wrapped in the curly brace strings {a:4[like];a:4[this]} and it does not land in the exact right database field.

    In these situations, all of the content (images, plugin files, etc) were transferred without a hitch, so it was just some of the data that was somehow corrupted.
    We did another SQL dump using ManageWP and used that SQL file (using PHPmyAdmin) and that imported just fine, though we had to search/replace for the old vs new URLs.

    If anyone stumbles into this error when doing an import and is also using Elementor: Uncaught TypeError: Argument 3 passed to Elementor\Core\DynamicTags\Manager::get_tag_data_content() must be of the type array, null given
    …that might be an indication your data was corrupted.

    Could be an Elementor problem but since the same data was exported via another source and that SQL file was loaded fine I therefore suspect Duplicator. (Which I dearly love— great job on this plugin for all other purposes!)

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.