Support » Plugin: Popups by OptinMonster - Best WordPress Popup Plugin » Need an account before you get anything.

Viewing 1 replies (of 1 total)
  • Erica Franz

    (@ericakfranz)

    My apologies for any misunderstanding, however, we do show clearly in the plugin description that an OptinMonster account is required to use the plugin: http://cloud.supportally.com/719cf7df8da4

    It isn’t our intention to mislead anyone.

    I do hope you’ll consider updating your review.

    All the best!

Viewing 1 replies (of 1 total)
  • The topic ‘Need an account before you get anything.’ is closed to new replies.