Support » Plugin: TinyMCE Advanced » <p>&nbsp ;</p> is added between captions

  • Hello,

    Thank you for your great plugin! It works very good since years 🙂

    But since the update to WordPress 4 an error appears. If the TinyMCE Advanced plugin is activated and the option “Stop removing the <p> and tags (…)” is activated I cannot place two images with caption together.

    If I place two images with captions together in one line in the editor, the following code is set by the editor:
    [caption id="attachment_65010" align="alignnone" width="200"]<a href="/2014/12/test1.jpg"><img class="wp-image-65010 size-middle_side_picture_size" src="/2014/12/test1.jpg" alt="Test 1" width="200" height="294" /></a> Image 1[/caption] [caption id="attachment_65011" align="alignnone" width="200"]<a href="/2014/12/test2.jpg"><img class="wp-image-65011 size-middle_side_picture_size" src="/2014/12/test2.jpg" alt="Test 2" width="200" height="294" /></a> Image 2[/caption]

    After pressing the save button, the code will be changed to the following:

    [caption id="attachment_65010" align="alignnone" width="200"]<a href="/2014/12/test1.jpg"><img class="wp-image-65010 size-middle_side_picture_size" src="/2014/12/test1.jpg" alt="Test 1" width="200" height="294" /></a> Image 1[/caption]
    <p> & nbsp ;</p>
    [caption id="attachment_65011" align="alignnone" width="200"]<a href="/2014/12/test2.jpg"><img class="wp-image-65011 size-middle_side_picture_size" src="/2014/12/test2.jpg" alt="Test 2" width="200" height="294" /></a> Image 2[/caption]

    The code <p> & nbsp ;</p> (without spaces) is inserted. What can I do to solve that issue?

    My installation: WordPress 4.0.1 with Multisite, TinyMCE Advanced 4.1.1, Browser cache deleted multiple times.

    Thank you for your help!

    Regards, Kristian

    https://wordpress.org/plugins/tinymce-advanced/

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘<p>&nbsp ;</p> is added between captions’ is closed to new replies.