Support » Fixing WordPress » NAVT Tool is broken…

  • Brand new install of WordPress with only a few pages.


    1. Navigation Management starts up correctly.
    2. Able to create multiple Group Names
    3. After pulling pages from uncategorized list and saving them, the group name will disappear.
    4. Not only will Group name disappear but many of the uncategorized pages will no longer appear in the list that were not even categorized.
    5. Resetting NAVT plugin data returns list to “virgin” form but the symptoms have been duplicated across IE and Firefox and 3 different computers.

Viewing 15 replies - 1 through 15 (of 15 total)
  • I have no idea what that NAVT tool you mentioned is.
    If it is a plugin – your best bet is to inform the author. In case it is not supported – at least provide some link, info… otherwise nobody understands what your post is about.

    OK, the NAVT Plugin is not working. Modifying that singular noun does not change the symptoms with the plugin that is called NAVT (as with the title of this plugin. The plugin is called the Navigation Tool and this support issue resides here: (see bottom of page)

    Further, the author of the plugin, on his site writes:

    Say it on here or say it there… Ask questions, report problems, make comments.

    This is the page that comes up when “there” is clicked upon.

    Rich Leino
    LtCol, USMC




    All I can say is wow. I too didn’t have a fricken clue what you were talking about. No need to be smug, he asked for clarification on what you were talking about. Thats all.

    forum volunteer, WordPress

    I wasn’t being smug. Maybe I’m ignorant about how this WordPress Support thing works but I posted my support issue in the spot where this plugin is. It appears with the plugin.

    Incidentally, the author of the plugin is a real pro. He found the problem with his code and already released a patched version.

    Thanks all!


    Resolved with version NAVT version 95.32

    New WordPress installation. v.2.2.1

    When trying to activate NAVT plugin, this error:
    “Plugin could not be activated because it triggered a fatal error.”

    I’ve used the plugin in other installations without trouble, cannot see why it doesn’t work.

    Must the “php_secure_mode” be deactivated?

    What else could happen?

    Thanks in advance.

    I also get the “Plugin could not be activated because it triggered a fatal error.” with a new 2.2.1 installation. Not sure what to check.

    Thanks very much

    I am experiencing the same error message with a recently upgraded installation of 2.2.2. Oddly enough, it worked when I installed it manually; I then installed the separate Pluginstaller plugin, which advised there was an upgrade available (thought the “upgrade” had the same version number). After the upgrade, the NAVT plugin could not be activated, even after disabling Pluginstaller and reinstalling it from the same zip I originally downloaded. The version is .95.37. The only thing I did with NAVT while it was working was to create one group and add to it three of my already established categories.

    I’m not at all sure what this problem is. I’ve read that people are having these problems. Unfortunately, I am unable to reproduce it with my setup.

    These issues seem more ‘arbitrary’ than ‘consistent’ for some reason.

    Recently, I’ve made changes to the activation routines – doing away with some of the code and overhead. I’ve also moved 98% of the entire plugin from scriptaculous to jQuery for the javascript framework. This move has improved the speed/ performance of the back-end software.

    Version 95.38 is due out soon with a large number of enhancements and new features. Including fixes for WordPress MU support along with a few minor changes for the upcoming WordPress 2.3 release.

    I’m in need of people willing to test what I have ready and to let me know about issues and problems they encounter.

    The software has grown to the point where it is almost too much for me to test by myself anymore.

    Are there any volunteers out there?

    To test the code you need to have an firm understanding of CSS for some of the new enhancements. It would be extremely helpful if you had a grasp on PHP – I don’t have a great deal of time to email out tutorials.

    If you would like to help me (and everyone that uses the plugin) send me an email at greg[AT]gbellucci[DOT]us and I’ll send you a copy of 95.38 to play with.

    Thanks for the 10,500+ downloads and the attention this plugin has received to date.

    – greg –

    A Word Press bug fix related to plugin activations on Windows platforms was put into the new Word Press 2.2.3 update. Read this trac entry for more information. NAVT calls the register_activation_hook() function and it is normally installed in its own subdirectory within the plugin directory. Download the Word Press 2.2.3 update and try activating NAVT again.

    Cant get it to work. First i allways got the information about dublicate NAV-GROUP names ! I cant eve see any Group in the NAVT admin tool ??? The when i use oterh names i can drag n drop my navigation. I save it on the right side, if this is save. then i put the code in my theme. an ERROR shows up on my site. back in NAVT menu my created menus are all gone.

    so how does it work ?

    It would be more useful if you explained what you did that produced duplicate names. Each group name must be unique and contain NO SPACES. If you try to reuse a name that exists it will complain about using a duplicate name.

    There is an APPLY button – not a save button. The script will tell you if the changes you made were saved or updated.

    It would also be useful to explain the error you see on your web site and the the code you created that you placed in your theme.

    What version of the plugin are you using?
    What WordPress version are you using?
    What browser and version are you using?
    What is your server environment?
    What OS platform are you running?
    Do you have Java Scripting enabled in your browser?

    There are literally pages and pages of information about how the plugin works and how to use it. It comes with a help file in the doc directory and the plugin has a home page and forum of its own.

    Having the same issue as WebsiteMaven who started this thread.

    Nav Group disappeared in the Manage NAVT page. Pages are present in Manage Pages, but not present in unassigned. Seeming that NAVT still holds the pages in the Group that has disappeared. A more mature site with many pages in another NAVT Group, so I really hate to have to delete and reconstruct.

    WordPress 2.2.2, (NAVT) V.95.37
    IE 7
    Apache Server running
    PHP 5.2.2
    MySQL client version: 5.0.16

    First, I’m wondering if there is a “maximum” number of pages that NAVT can handle? I’m nearly at 300 pages.

    If not, is there a fix? I’m somewhat knowledgeable (hey, I know how to do backups to recover 🙂 to dig around and fix the error. I’m 20 years online/Internet, but coding and debugging is not my main game, or I’d volunteer for testing the 95.38 beta.



    I am getting the fatal error message when I try to activate the plugin too.

    I have just updated to WordPress 2.3.1. and NAVT version.95.45.

    Am I missing something?
    Thanks for the plugin.

    You might try increasing the memory setting in your php.ini file. The memory setting should be 16M or higher to run WordPress and plugins safely.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘NAVT Tool is broken…’ is closed to new replies.