Support » Plugin: qTranslate X » Navigation problem

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author John Clause

    (@johnclause)

    I cannot observe the problem you described, all seemt to work for me. Try restart browser, maybe it is some caching problem. If the problem persists, please, give us specific instructions how to reproduce.

    I can’t keep it activated or the website won’t work. I reactivated it for a few and it still wasn’t working. I took a screenshot of the url with the problem. You can see it at this link

    View post on imgur.com

    Plugin Author Gunu

    (@grafcom)

    @erikas,

    how are your settings in the qTranslate X setting page and in the WP permalink settings?

    Plugin Author Gunu

    (@grafcom)

    Try under Settings – Languages – Advanced Settings:

    Check – Use Pre-Path Mode (Default, puts /en/ in front of URL). SEO friendly.

    instead of:

    Use Query Mode (?lang=en). Most SEO unfriendly, not recommended.

    Ok it fixes it! But now it automatically redirects me to the ITALIAN page, I unchecked the option “Detect the language of the browser and redirect accordingly” but it still redirects me automatically to the italian one and I don’t want this to happen

    Plugin Author Gunu

    (@grafcom)

    delete cookies and cache and restart brower, than you have a “clean” start point.

    It doesn’t work all the time. Sometimes it does and sometimes it doesn’t.

    Plugin Author Gunu

    (@grafcom)

    What does it sometimes and what not?

    The language switching in the blog posts or the redirects?

    Sometimes the redirects gets stuck on the second languages without letting you go back to the default one

    Plugin Author Gunu

    (@grafcom)

    is that always at the same point/post?

    When I delete the /it/ manually it doesn’t always switch

    Plugin Author Gunu

    (@grafcom)

    that is normal, because your cookie “think” you look at the site in Italian…..

    But with the language changer it works now anyway?

    Yes with that it does 🙂 Thank you

    Plugin Author Gunu

    (@grafcom)

    @erikas,

    You are very welcome! You can review this plugin to help other people to find out the value.

    I mark this topic as Resolved.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Navigation problem’ is closed to new replies.