WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Navigation links after moving WordPress (11 posts)

  1. bdgarfield
    Member
    Posted 4 years ago #

    Hello, potential helper,

    Today, I moved my wordpress installation from local to live and did all the required changes in order for the thing to work. And it works.

    Except for one thing, my navigation links all seems to point at the wrong place, how can I change that other than in the pages settings?
    The home link seems to work fine though.

    Any idea? I probably overlooked something stupid, as usual, but I can't seem to find it this time.

    Thanks in advance

  2. Snaggletooth
    Member
    Posted 4 years ago #

    Is the navigation static? Then look in header.php.
    Otherwise search your db for 'localhost' or '127.0.0.1' to see if there's anything unchanged left.

  3. bdgarfield
    Member
    Posted 4 years ago #

    Thanks for the help,

    I juste checked my db, no traces of localhost or 127.0.0.1 left.
    How can I know if my navigation is static?
    It's generated by the theme and wordpress if that's what it means, so I guess it's dynamic.

    Any other idea?

  4. Snaggletooth
    Member
    Posted 4 years ago #

    When you generated the navigation in wp admin it's not static.
    Where do the links point to and where should they point to?

  5. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    did you regenerate your permalinks?

  6. bdgarfield
    Member
    Posted 4 years ago #

    My permalinks look okay, they point to te folder where index.php lies /'name of the page' wich worked in local.
    I tried creating a new page in order to see if the problem would persist, and it does, even new pages have bad links in them.

    What could it be?

    Thanks again for the help.

  7. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    sometimes, you just have to regenerate permalinks to fix things.

    save back to default, test your site, save back to custom

    I don't understand your reply...? permalinks is not the settings in general settings

    Its the settings in your permalinks menu..... they don't point to any folder...

  8. bdgarfield
    Member
    Posted 4 years ago #

    Ho, I thought you were refering to the permalinks shown when you edit a page, my bad.
    I changed the permalinks to default, it worked.
    I changed back to the month and name setting, the one I want, and it tells me to update my .htaccess file.
    How do I do that?

    Thanks for your answers

  9. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    hmm... well, usually the .htaccess file is writeable, but not for you unfortunately.

    Either use ftp software (I use filezilla) to get on your host to edit the file

    or hopefully your host offers some sort of file manager, most do these days.

    the .htaccess is in the wordpress root. so if you installed wordpress to root (public_html, html, etc) the .htaccess file is/goes there

  10. bdgarfield
    Member
    Posted 4 years ago #

    I edited and uploaded the .htacess file on the server, but the links still won't work.
    What could it possibly want more?
    Thanks again.

  11. bdgarfield
    Member
    Posted 4 years ago #

    Any idea, anyone?

Topic Closed

This topic has been closed to new replies.

About this Topic