WordPress.org

Support

Support » Themes and Templates » Navigation bar in header is sadly broken

Navigation bar in header is sadly broken

  • My entire post vanished above.

    I have nearly wiped out my theme trying to do this all night. It is Blackgrey. Every time I try to fix it, all the tab links move over. http://donnabarstow.com/WordPress/
    None of the tabs correspond to the pages. I think the header php is broken, as it doesn’t have wp_link in it. When you hover on the tabs, it has a # sign, so I tried adding each page in by hand in the headerphp, but that didn’t work either.
    I also tried uploading wp_navi, but it is invisible in my plugin section.
    Can someone please help??

Viewing 3 replies - 1 through 3 (of 3 total)
  • Are you the theme author? If not, reinstall the theme completely, or try someone elses.

    The nav area looks butchered. Not sure why there is a table stuck in there.

    Hi, Mark, no, I’m not the author! What I did was try to take out some of the tab names such as register, etc, because I didn’t need them. Then the search box moved over. I can fix that in the css.
    But maybe you’re right, the nav area is butchered. Isn’t there something I can add to make it work? I’ve put a couple weeks into trying to make this theme look good.

    Short of explaining inline lists for navigation, check out this:

    http://css.maxdesign.com.au/listamatic/

    take a look at the examples, and use the generator if needed. Replace the entire table that is being used for the navigation with an unordered list.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Navigation bar in header is sadly broken’ is closed to new replies.