Support » Plugin: FooBox Image Lightbox WordPress Plugin » Navigation arrows, close button, and loading icon won’t show

  • Resolved ghostintheshell

    (@jacopolupi)


    I can’t see the icons on the lightbox. Buttons work but the assets are not shown on Safari.
    I can see a frame shaped placeholder icon on Chrome and some weird ‘E000’ ‘E001’ ‘E002’ icons on Firefox.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • I have the same issue with http://dev.hornchurchcc.org/hcc-photo-gallery/gallery/youth-team-june-2015/#hornchurch-cc-youth-album

    Everything works fine on the live site http://hornchurchcc.org/photo-gallery/gallery/youth-team-june-2015/#hornchurch-cc-youth-album

    My issue is Firefox and Chrome based. Not tried on Safari. All settings are exactly the same and am using FooBox Lightbox for both sites.

    Any help or ideas would be muchly appreciated..

    RickM

    NZ

    Hey, I have also the same problem. It would be nice if somebody could help us with support.
    No correct icons and in mobile view I see chinese??
    https://www.hasifrett.de/hasifretts-bildergalerie/

    Greetings, Dan

    Plugin Support phillcoxon

    (@phillcoxon)

    Hi @jacopolupi,

    I’ve been looking back through support requests and noticed we missed your request at the time. I’m sorry about that. Checking your website I can see that FooBox is still now showing the correct navigation icons.

    Would you please respond and let me know what version of FooBox you are running?

    @steveush – are you able to give some feedback on why the navigation font icons are not displaying correctly on this site?

    Hi All,

    These are two different issues so I’ll address each as such:

    @jacopolupi the issue is simply some custom CSS being inserted into your page which is forcing all elements to use a specific font. On line 160 of your linked page there is the following being output by another plugin, I think something along of the lines Easy Google Font Styles?

    <style id="tt-easy-google-font-styles" type="text/css">p { }
    h1 { }
    h2 { }
    h3 { }
    h4 { }
    h5 { }
    h6 { }
    * { font-family: 'Roboto Slab'!important; font-style: normal!important; font-weight: 100!important; }
    </style>

    FooBox’s icons are supplied as a font, this bit of CSS is forcing every element in the page to use the Roboto Slab font due it it applying the font using the * selector and the !important keyword. I would suggest removing this plugin or contacting it’s author about how to alter his plugins output.

    @rickmnz as it is working live but not on dev I believe the issue might be related to either the server not being configured to serve font files, I see this quite regularly. Or the issue may have been that the url’s on dev were pointing to the live assets and were denied due to a CORS error. As dev is no longer available I can’t say for certain but hopefully this can help you out if the issue reoccurs.

    @hasifrett I see yours is also working now on your site, from what you described I think the issue was similar to @rickmnz’s.

    Thanks

    HI, I am facing the same problems here but with FooGallery.
    https://alohatosea.com/quotes-messages/love-quotes/beautiful-love-quotes/
    Please tell me how to make the close/arrows show?

    • This reply was modified 5 months, 3 weeks ago by wpz118.

    Hi @wpz118,

    I’ve just had a look at your site and you’re not using FooBox on that page at all. If you’re needing help with the lightbox used with the feature image I believe that might be part of your theme?

    Thanks
    Steve

    @steveush
    Sorry I just realized I failed to use lightbox in setting for foogallery. Now it is working. Thank you.

    • This reply was modified 5 months, 3 weeks ago by wpz118.
    • This reply was modified 5 months, 3 weeks ago by wpz118.

    @steveush Sorry for my late reply. You are right, I unchecked the option that enables the !important keyword and it seems to work without having to switch off the typography plugin. Thank You. Best

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.