Support » Fixing WordPress » Nasty P (Sidebar problems)

  • Hello,

    I just installed a theme to my new blog (NFOoverload) and I’m getting this really annoying problem.

    In my sidebar, the pages title is displayed only with a “P”. I can’t seem to find where that thing can be changed. I’m leaving a link to a cropped screenshot so you can visualize about what I’m talking about.

    How can I replace that with the full menu title?

    http://img30.imageshack.us/img30/4656/problem0fi.gif

    Thanks!

    -Daiver

Viewing 13 replies - 1 through 13 (of 13 total)
  • Looks bad! It’s hard to see what causes this behavior.It might be that the title is presented within a div or other box with a witdth set in the CSS stylesheet.

    If you give us a link to your blog it would be easier to judge!

    Alright, it’s http://www.indieradio.com.ar

    I’m still searching for the problem and I can’t find it. It’s quite annoying.

    Thanks!

    It will seem that the “P” is generated by your theme, but it doesn’t look like a page title.
    The P has a class of “pagenav” and looks more like a heading for the list of pages.
    Just under the P follows “Información” which *is* a link to a Page. This is the first line in an ordered list and has the class “page-item”.

    Your “P” may come from a hard coded heading in your sidebar.php page.

    So you’re saying that it has to be in the sidebar.php file? I’ll look again and replace whatever seems to be the problem then.

    In the sidebar.php you should have a line that says:
    <?php wp_list_pages('title_li=<h2>' . __('Pages') . '</h2>' ); ?>

    The ‘P’ comes from the argument to __(‘Pages’) wp_list_pages, which should give a title to the list of Pages.
    ( Full explanation here http://codex.wordpress.org/Template_Tags/wp_list_pages )

    Check that the line above is correct in sidebar.php
    As it stands, it only outputs a ‘P’, so it has nothing to do with your styles.

    That line in the sidebar.php is exactly like you wrote it there. I really didn’t understad what’s in the link you posted, it’s like the Matrix to me.

    Any other ideas?

    I still haven’t found it 🙁

    I validated with w3 and surely it gave me this error:

    Error Line 129 column 31: document type does not allow element “ul” here; missing one of “object”, “applet”, “map”, “iframe”, “button”, “ins”, “del” start-tag.

    <li class="pagenav"><h2>P
    <ul><li class="page_item current_page_item"><a href="</code"></a></ul>

    The problem is that I don’t know where to find it. I’ve searched every single PHP file and nothing turns up.

    I’m still having this problem. Can anyone plase help me? I’m starting to pull off the hairs on my head. 🙁

    I give up. 🙁

    Don’t give up that quick 🙂
    I’ve had a similar problem in that “Pages” translates to “Pagina’s” in Dutch, which left me with a big problem using the ‘apostroph’ sign in the php-code.

    However, seeing your problem, I suspect the answer is in either of two files:
    – the translation file of your site (located in /wp-includes/languages/something.mo)
    – the “wp-list-pages” function in the /wp-includes/template-functions-post.php file

    So, first turn off the translation (in the wp-config.php file) and see whether it says “Pages” again. If it does, I suspect the translation file to be faulty or using characters the function wp-list-pages doesn’t support.

    Else, use the solution that I used: edit the function wp-list-pages in the abovementioned file. But, reading your reactions, I doubt whether you’re easy to read through the lines and hard-code the translation into that function. Anyway, this is the least elegant way to tackle the problem.

    Success.

    Anne-Marie

    (@caramellamorbide)

    Daiver….did you change anything before the P started to show up? I installed the theme in my test blog, just to see if there might be something wrong but it’s all validated http://www.photos.seacloudies.com/wordpress/
    Have you tried uninstalling and installing a fresh new download?

    Hi, thanks for the replies and sorry for being so late.

    I had kind of abandoned working on it and just saw this thread in my bookmarks.

    I’ll try those things and see if it helps.

    Caramella, if I go back to the original theme it gets fixed, so I suspect it has something to do with the translation file, which is just about the only place where I haven’t looked.

    I’ll get on it and let you guys know. Thanks!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Nasty P (Sidebar problems)’ is closed to new replies.