WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Nasty ERROR with latest Version!!!

[Resolved] Nasty ERROR with latest Version!!!

  • Warning: in_array() expects parameter 2 to be array, boolean given in /plugins/groups/lib/core/class-groups-user.php on line 246

    This error shows up all up and down the page…

    This appears to be in some way caused by w3 Total cache…I’ve disabled cache for logged in users and cleared the site cache and the issue appears to have resolved.

    But worth looking into…

    http://wordpress.org/extend/plugins/groups/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author itthinx

    @itthinx

    Thanks for reporting it Jason, I’ll have a look at what’s causing it.

    Plugin Author itthinx

    @itthinx

    I’ve tried to get this error to happen on a test site with W3 freshly installed and a few hundred users but it doesn’t appear. Anyhow, I see when it can happen from the code, so I’ll review it and issue an improved version. Thanks again for reporting it 🙂

    Actually, I ended up getting it to happen again with w3 total cache off — so I think that was a red herring…

    I switched out back to the older version and looks like that took care of it for now.

    Plugin Author itthinx

    @itthinx

    Fixed it, if you’d like to try it, it’s already in the trunk.

    Awesomeness!

    Plugin Author itthinx

    @itthinx

    Thanks again Jason, version 1.3.10 is now ready, please give it a try 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] Nasty ERROR with latest Version!!!’ is closed to new replies.