Support » Plugins » narchives included in index?

  • I wanted to avoid having to update narchives every time I changed something in the menu, etc., so I decided to try and include it in the index page. I got all the rewrite done and stripped the menu, etc. from narchives but how do I overcome the posts_per_page set in the blog-header? My regular page shows 5 posts and ’tis all narchives will show when included.
    To further clarify, I have at the top of my index page:
    <?php
    $narchives = $_GET['narchives'];
    if ($narchives == 1) {include('narchives.php');} else { ?>

Viewing 5 replies - 1 through 5 (of 5 total)
  • I plan on getting back to this so if anyone has any ideas that might save me some time, I would appreciate it.

    Beel, the way I described it, posts_per_page never comes into the picture at all! I am confused about how you did it, and please try out the method i described and see if it works.

    the $posts_per_page might be used by a function in narchives, and that must have defined it as a global.
    Try editing the occurences of global $posts_per_page in the functions in narchives.php which use that variable, or try try defining the $posts_per_page='-1' as a global.
    I think it might be the variable scope that’s the issue, that’s a clue, maybe you can use that, ’cause variable scope is confusing for me 🙂

    Thanks 2fargon, when I got home last night the “Edit” from my last post did work (but I am still on my search to find a “nonedit-blog-header” answer). I just checked and if I put &showposts=50 in the link the $posts_per_page set in options is overridden so I think all I have to do is set that in htaccess. I will check when I get back home.

    Beel, that worked for me as well. Thanks for answering this question before I could ask it. ;]

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.