Support » Everything else WordPress » Nameservers not registered

  • Hi,

    I purchased a VPS for my domain, registered with and want to point my domain towards it. But upon editing nameservers, I am receiving Nameservers Not Registered message. I tried several times and consulted several people but nobody could suggest me any solution. Even I dropped three emails in last three days to WordPress Support but nobody responded yet.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    I see no problem… your site looks fine and is clearly a selfhosted domain 🙂 You’re good.

    Did you PURCHASE your domain via or your webhost?

    Thank you for reply.

    It is NOT doing good. Let me tell you little history. I had a shared hosting plan earlier with my hosting company. Than I purchased a VPS for me and wanted to bring my domain to this virtual server. That’s where the problem is.

    I am unable to update my nameservers to point it to towards my server. I am handling my domain from that shared hosting so far, that’s why everything is fine apparently but i’ve received several emails since I setup my VPS with the following content:

    Your hostname ( could not be resolved to
    an IP address. This means that /etc/hosts is not set up correctly,
    and/or there is no dns entry for Please
    be sure that the contents of /etc/hosts are configured correctly,
    and also that there is a correct ‘A’ entry for the domain in the
    zone file.

    Some or all of these problems can be caused by /etc/resolv.conf
    being setup incorrectly. Please check that file if you believe
    everything else is correct.

    You may be able to automatically correct this problem by using the
    ‘Add an A entry for your hostname’ option under ‘Dns Functions’ in
    your Web Host Manager.

    And yes, I purchased my domain via and how it is self-hosted wordpress site.

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep, is fine though, as I said. You didn’t mention subdomains being borked 😀

    Clearly you were able to point the DNS correctly at some point. Do you remember how you did THAT?

    IIRC all the directions you need are here:

    They even link you to the CUSTOM DNS section, which is what you need

    I followed instructions given on mentioned links but still no success. I am unable to point my domain to my virtual private server. Current DNS are NS81.MOCHAHOST.COM and NS82.MOCHAHOST.COM, which I added last year, now I want to replace them with and But still it is giving error ‘nameserver not registered’. Please advice how to fix the issue or refer me to relevant person.

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    What’s in your DNS values?

    Looks something like this:

    MX <pref> <host>.
    TXT <text>
    CNAME <subdomain> <host>.
    A <subdomain> <IP>

    Yours would include (I THINK! THE IP MAY BE WRONG!!!!)



    A ns1
    A ns2
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Nameservers not registered’ is closed to new replies.