Support » Plugins and Hacks » [Resolved] Name split…

[Resolved] Name split…

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Danny van Kooten


    Exactly, that should just work. When a NAME is given but no FNAME andLNAME`, the plugin will split the name automatically and send all three values.

    Are your MailChimp list fields for first- and lastname named FNAME and LNAME?

    Yeah. The email goes through but FNAME and LNAME are left blank. Maybe I will cheat and just use FNAME and label it Name on my form.

    BTW,not sure this is a bug or it is just me, but I noticed that when I upgraded your plugin, the check box for adding a Mailchimp list disappeared. Then the message appeared under my form that I needed to add a list. I had to unintsall and reinstall the plugin to get the check box to come back.

    Plugin Author Danny van Kooten


    Hmm. That should not happen (both issues).

    What version were you upgrading from? Are you now on the latest version and it is working?

    The form should be split automatically. Do you have an URL where I can see an example of your form? That would be really helpful.

    I believe it happened from the last version to the latest version. Maybe it was a fluke. I just wanted to give you a heads up just in case someone else says something similar. It took me awhile to realize the little check box was gone and something was up.

    The site isn’t public yet, but below is the source code output. Everything looks normal.

    <!-- Form by MailChimp for WordPress plugin v1.4.2 - http://dannyvankooten.com/mailchimp-for-wordpress/ -->
    <form method="post" action="#mc4wp-form-1" id="mc4wp-form-1" class="mc4wp-form form "><div class="controls controls-row">
    <input class="span6" name="NAME" placeholder="Name" type="text">
    <input class="span6" required="required" placeholder="Your Email" name="EMAIL" type="email">
    <p><input value="Send" type="submit"></p>
    </div><textarea name="mc4wp_required_but_not_really" style="display: none;"></textarea><input type="hidden" name="mc4wp_form_submit" value="1" /><input type="hidden" name="mc4wp_form_instance" value="1" /><input type="hidden" name="mc4wp_form_nonce" value="9aab2a77a8" /></form>
    <!-- / MailChimp for WP Plugin -->
    Plugin Author Danny van Kooten


    Hi there,

    Turns out this was a bug in my code, which I only addressed in the premium version. Great catch, thanks a lot. Fixed it in version 1.4.4, your mark-up should work now. 🙂

    Great. Thanks for the follow-up!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] Name split…’ is closed to new replies.