Support » Fixing WordPress » name lookup timed out

  • Resolved CharlesClarkson



    I have had trouble installing Plugins since I upgraded to WP 2.6. I get this error during FTP.

    Download failed.: name lookup timed out

    I have three main blogs. One is on a Windows server. Everything works fine there, but the two Linux accounts are giving me this same error. I deleted one and installed WP 2.7 from scratch and I still cannot use the auto install to add Plugins by FTP. I can do it manually.

    Apparently, the windows system doesn’t use FTP to do the install or at least I am not asked for FTP credentials each time something is updated on that blog. (There’s an annoying feature which needs to leave, but that is for another post.)

    The Linux servers stats are:
    Apache version 2.2.6 (Unix)
    PHP version 5.2.5
    MySQL version 4.1.22-standard
    Architecture i686
    Operating system Linux
    Kernel version

    I have had this trouble since the 2.6 upgrade. My host has not reported any change on their end which might have occurred while I was upgrading. I doubt it is a hosting problem. On the other Linux blog, I cannot update old Plugins.

    Has anyone else run into this error?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Im having the same error here, using Host Gator. Same thing when trying to upgrade my plugins..

    My host found this more recent post, but it looks like his problem just fixed itself.

    I’m examining my FTP logs now. Perhaps I’ll get a clue. 🙂

    I tried changing a few settings in the Settings control panel on WordPress. No luck there. I also removed the .htaccess files to see if it was rewrite problem. Still no luck.

    I just tried adding a plugin from my own hard drive instead of downloading it directly from the WordPress servers though that is where it came from. I used the WordPress Plugin interface and everything is fine. That is still mighty convenient. No more unzipping files locally.

    I think the problem is on the WordPress side or at least it is a problem between my hosts’ servers requesting a file from the WordPress download servers. One of the many failed downloads from WordPress follows as an example.

    While studying this problem I came across some similar problems where the FTP program was using PASV which needed to be defeated. Perhaps there is a similar setting somewhere on my hosts’ server which is incompatible with (Server hardware is a big black box to me. I have little idea what I am talking about.)

    I’ll keep an eye out for others with this same problem. Maybe something will pop up.

    That topic on adding the /etc/hosts works for me. Thanks for posting it up.

    Dion Hulse


    Core Developer

    Just a quick note, That error is probably coming from the cURL HTTP module, The problem with using the /etc/hosts workaround is that it only fixes GET requests for, Things like Pings, Core-update checking, and possibly Cron in a future release will still be broken.

    See my post here: for a way to disable the actual component causing the error, It’ll simply fall-back onto a different component which will most likely work.

    Neither the hosts file nor the Core Control Plugin worked for me. The tests passed on some options in Core Control, but the result of the update for a plugin is always the same. I tried deactivating each part on Core Control and I think I got every combination (or is that permutation).

    At one point I had everything off and rec3eived a different error, but things still failed. This is an experimental blog and I have the opportunity to move it to another linux host. I’ll post an updatehere if I am successful after the move.

    I am using the Simplicity Theme and I also tried updating it to the latest version of it. No Joy.

    I just tried switching themes to WordPress Default. Still no Joy.


    I have moved this blog to another host and the problems have ended. Please feel free to close this thread.


    I had the SAME problem on my blog: Cash Bootstrap Method

    I have the WP-Spamfree plugin installed. For some reason it would just not update. I disabled and re-enabled it. Changed the plugin directory permissions and after several hours it still didn’t work.

    Now I’m not sure if this has any relevance, but I downloaded the NEW version in ZIP format and went to “Add New” under plugins and attempted to add it.

    Obviously it failed as it said it already existed.

    But when I went back to the plugin (wp-spamfree) and ran another “automatic upgrade” it worked!

    Weird? I’d say. But it’s working again.

    Hope this helps someone 🙂


    This is an intermittent problem for me; I solved it by disabling cURL using the Core Control plugin as described in this post:
    Here are the details:

    Download and install this plugin manually: Once you’ve activated it, Load the “Core Control” settings page and activate the “HTTP Module”. Go to the new tab fore the “HTTP Module” and test cURL. You will most likely receive the following error message “An Error has occured: name lookup timed out” Now click the “Disable Transport” link in for cURL. You should now be able install plugins and plugin updates.

    Here is the bug report:

    THANK YOU!!!!!!!! This solved the problems I was having re: using WP’s autoupgrade function as well as re: auto-upgrading plugins. Appreciate it very much!! 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘name lookup timed out’ is closed to new replies.