Support » Themes and Templates » Mystique – TweetMeMe doesn’t work with Featured Posts.

  • Resolved pkoury

    (@pkoury)


    When I turn on the featured posts option in the Mystique theme, the TweetMeMe buttons disappear. When I turn it off, the buttons come back.

    Any idea why this might be or how to correct it?

    I am using the latest versions of everything as of today.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Anyone?

    you can’t make it work unless you turn off featured posts.
    this because of bad plugin coding.

    more exactly, the plugin author hooks his function on “the_content()” without making sure the_content() is called within the main loop & not on other stuff (like the featured posts in this case)…

    if you know php I could tell you how to fix this, you’ll need to edit the plugin code.

    I’m willing to give it a shot if you are. I have done some pretty advanced stuff and I’m pretty good at following directions. 🙂

    open tweetmeme.php and replace
    add_filter('the_content', 'tm_update');
    with:
    add_filter('the_content', 'tm_update', 8);

    Wow, that works.

    Why does adding the ‘8’ make a difference? I am going to report this to TweetMeMe.

    8 is the priority for the hooked function.
    you need that so the filter is added before get_the_excerpt calls the_content.

    Thanks a bunch. I have notified TweetMeMe. Awesome support!

    TweetMeMe released an official update today correcting this problem!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Mystique – TweetMeMe doesn’t work with Featured Posts.’ is closed to new replies.