WordPress.org

Forums

WooCommerce
[resolved] Mystile gives error (4 posts)

  1. Stacy (non coder)
    Member
    Posted 3 years ago #

    The free theme for this plugin gives an error in in my footer out of the box.
    "/public_html/wp-content/themes/mystile/functions/admin-functions.php on line 3193". It had something to do with google fonts. I haven't made any font changes as yet. Turning the option for typography on and off has shown no difference. The other themes do not have this part coded exactly the same but editing it based on those has not worked.

    } // End wooframework_display_theme_version_data()
    }

    if ( ! function_exists( 'wooframework_load_google_fonts' ) ) {
    function wooframework_load_google_fonts() {
    global $woo_used_google_fonts;

    $c = 0;
    $fonts = '';
    foreach( $woo_used_google_fonts as $font ) {
    if( $c > 0 ) {
    $fonts .= '|';
    } else {
    ++$c;
    }
    $fonts .= $font;
    }

    woo_shortcode_typography_loadgooglefonts( $fonts , 'woo-used-google-fonts' );
    } // End wooframework_load_google_fonts()
    }
    add_action( 'wp_footer' , 'wooframework_load_google_fonts' );
    ?>

    http://wordpress.org/extend/plugins/woocommerce/

  2. Stacy (non coder)
    Member
    Posted 3 years ago #

    "Invalid argument supplied for foreach()"

  3. James Koster
    Member
    Plugin Author

    Posted 3 years ago #

    Hey,

    Have you tried updated the WooFramework to the latest version? That should resolve this issue.

    You can also turn wp_debug off to hide the warning (probably best on a live environment anyway).

    Thanks

  4. Stacy (non coder)
    Member
    Posted 3 years ago #

    Yaaaay. Thank you so much

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.