WordPress.org

Support

Support » How-To and Troubleshooting » Mysterious blank column is expanding page. Help!

Mysterious blank column is expanding page. Help!

  • Hello,

    I’ve just about finished my layout for this site, when a friend pointed out that I’m getting a horizontal scroll bar, where there’s no actual content when you scroll over to the right.

    Using firebug, I can see there’s some element there that it can highlight, which seems to be a blank column visually. The mystery is that it doesn’t show any code associated with it. Instead it just shows this html tag in the code <html xmlns="http://www.w3.org/1999/xhtml">

    The quick info says it’s an HTML node with 1265px width, but I have no idea how this is being generated or where it’s coming from. It’s not part of the container at all.

    The site is:http://salmeland.com/blog/

    My stylesheet is below.

    Thanks for your help here!

    [CSS moderated as per the Forum Rules. Please post a link to your site instead.]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator Michael

    @alchymyth

    Forum Moderator

    Any help here? It’s such a curious problem since it doesn’t seem to stem from my CSS at all. I’m not sure how to address it. Thank you.

    Yeah. It looks like it is in your CSS. Change this:

    .container {
    	width: 980px;
    	margin-left: auto;
    	margin-right: auto;
    }

    to this:

    .container {
    	width: 960px;
    	margin-left: auto;
    	margin-right: auto;
    }

    It’s happening because your background image is 960px wide and the container is set to 980px.

    Hi there,

    Thanks for your response.

    The background jpeg is 1199px and that’s in the body tag, not the container.

    Changing the container size didn’t get rid of the scrollbar.

    I don’t understand what is forcing the page wider because when you scroll, there’s nothing there at all.

    Weird. I see you did change the .container size to 960px, and for me the scroll bar is gone. I did see it before, but it looks like you fixed the issue. At least in Firefox and Safari.

    Hm, it’s definitely still there for me in both browsers. Maybe you have a widescreen monitor.

    Can anyone else take a look and make any suggestions to eliminate this useless horizontal scrollbar?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Mysterious blank column is expanding page. Help!’ is closed to new replies.