Support » Fixing WordPress » MySQL/PHP Upgrade Problems

  • Resolved Chip Bennett

    (@chipbennett)


    Theme Review Admin

    My hosting service updated my domain to a server running newer versions of PHP and MySQL (at my request, to support WP 2.1 requirements).

    The migration was completed, but now WordPress is generating 500/internal server errors.

    I have a ticket in with my host’s tech support, but I was wondering if anyone here had run into anything similar?

    The server error log keeps repeating:

    [Thu Jan 25 18:49:58 2007] [error] [client 74.6.68.157] PHP Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 87 bytes) in /var/www/html/wordpress/wp-content/plugins/wp-db-backup.php on line 766
    [Thu Jan 25 18:49:58 2007] [error] [client 74.6.68.157] Allowed memory size of 8388608 bytes exhausted (tried to allocate 10 bytes)
    [Thu Jan 25 18:49:58 2007] [error] [client 74.6.68.157] Premature end of script headers: php-script

    So far, my host’s tech support has suggested changing the wp-config.php file so that DB_HOST is “127.0.0.1” instead of “localhost”.

    Is this a server problem, or is this a wordpress problem?

    I have the database backed up, and can get into it via MyPhpAdmin (can back it up again, do anything with it on the server side), but wordpress can’t seem to access it.

    Thoughts?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Based on the errors…

    Ask the host to configure PHP to give more than the default 8MB for max memory.

    Or deactivate some plugins to fit in 8MB.

    Chip Bennett

    (@chipbennett)

    Theme Review Admin

    Assuming that’s the problem, how do I remedy it?

    I can’t get to my plugin page, because every attempt to bring up a wordpress-related page (main index, admin dashboard, etc.) results in either a blank page (index) or the 500 intternal server error page. Thus, I can’t get *to* my plugins page to disable anything.

    Everything’s backed up. Should I just blow everything away, and load a fresh copy of WP 2.1?

    (I’m also putting in the request now, to have the PHP memory allocation increased.)

    Thanks!

    Chip Bennett

    (@chipbennett)

    Theme Review Admin

    (I should have thought of this originally, but I’ve not had any coffee yet this morning.)

    I moved several plugins out of the “plugins” directory and into a temp directory, and everything seems to work as expected. Looks like you were exactly right. Thanks!

    Note to self: deactivate plugins that you try, and then decide not to use!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘MySQL/PHP Upgrade Problems’ is closed to new replies.