• WebCodePoet

    (@senjoralfonso)


    I am getting following error:

    [Sat Apr 08 14:44:57.241196 2023] [proxy_fcgi:error] [pid 2510:tid 140542438540864] [client 85.114.55.14:0] AH01071: Got error ‘PHP message: PHP Warning: mysqli::__construct(): (HY000/2002): No such file or directory in /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/cf7-antispam/includes/cf7a-antispam-b8.php on line 51; PHP message: PHP Fatal error: Uncaught Error: mysqli object is already closed in /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/cf7-antispam/vendor/l3u/b8/b8/storage/mysql.php:44\nStack trace:\n#0 /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/cf7-antispam/vendor/l3u/b8/b8/storage/mysql.php(44): mysqli->real_escape_string()\n#1 /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/cf7-antispam/vendor/l3u/b8/b8/storage/storage_base.php(115): b8\storage\mysql->fetch_token_data()\n#2 /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/cf7-antispam/vendor/l3u/b8/b8/storage/storage_base.php(98): b8\storage\storage_base->get_internals()\n#3 /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/cf7-antispam/vendor/l3u/b8/b8/b8.php(116): b8\storage\storage_base->__construct()\n#4 /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/cf7-antispam/includes/cf7a-antispam-b8.php(75): b8\b8->__construct()\n#5 /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/cf7-antispam/includes/cf7a-antispam-b8….’, referer: https://www.domain.com/contact/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Erik

    (@codekraft)

    Thanks @senjoralfonso for the error report, i will look into it right away! Which PHP version are you using? Are you sure the php module MySQLi is enabled and is working?

    • This reply was modified 1 year, 1 month ago by Erik.
    Thread Starter WebCodePoet

    (@senjoralfonso)

    Latest, 8.2.3

    Plugin Author Erik

    (@codekraft)

    Thank you for the clarification @senjoralfonso, I added a workflow for the latest php version but in the CI the tests seem to pass correctly so i need to take a look closer.

    Does this happen to you when installing/updating the plugin or during normal plugin execution? I ask so I can write a test that covers this case too, if possible! thanks again!

    Thread Starter WebCodePoet

    (@senjoralfonso)

    Hey @codekraft it happens during normal operation.

    Thread Starter WebCodePoet

    (@senjoralfonso)

    Maybe this helps, it is from day, but seems to be the same error as well.

    Got error 'PHP message: PHP Warning:  mysqli::__construct(): (HY000/2002): No such file or directory in /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/cf7-antispam/includes/cf7a-antispam-b8.php on line 51; PHP message: PHP Fatal error:  Uncaught Error: mysqli object is already closed in /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/cf7-antispam/vendor/l3u/b8/b8/storage/mysql.php:44\nStack trace:\n#0 /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/cf7-antispam/vendor/l3u/b8/b8/storage/mysql.php(44): mysqli->real_escape_string()\n#1 /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/cf7-antispam/vendor/l3u/b8/b8/storage/storage_base.php(115): b8\\storage\\mysql->fetch_token_data()\n#2 /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/cf7-antispam/vendor/l3u/b8/b8/storage/storage_base.php(98): b8\\storage\\storage_base->get_internals()\n#3 /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/cf7-antispam/vendor/l3u/b8/b8/b8.php(116): b8\\storage\\storage_base->__construct()\n#4 /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/cf7-antispam/includes/cf7a-antispam-b8.php(75): b8\\b8->__construct()\n#5 /var/www/vhosts/domain.com/httpdocs/wp...', referer: https://www.domain.com/contact/
    Plugin Author Erik

    (@codekraft)

    Ok confirmed, and thank you for the report @senjoralfonso! I also got some issues running the plugin with php8.2.x (you can test the plugin with wp-env, just replace this line with the version you want to give a try), so i guess that I need to update the plugin to get it working with WordPress… BTW, currently also the latter doesn’t fully support php 8.2,so i think it isn’t advisable for the time being to switch to it

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘MySQLi Error’ is closed to new replies.