Support » Installing WordPress » mysqladmin ping works, but WP can’t connect

  • Our server runs several separate MySQL servers, each listening to its own port and socket.

    Doing a mysqladmin -S /tmp/mysql-oopsblog.sock -u root -p ping and supplying the password returns “mysqld is alive”.

    DB_USER is “root”, DB_PASSWORD is the same I enter to mysqladmin, and I’ve tried the following DB_HOST settings:

    * localhost:4003 (the port mysqld listens to)
    * localhost:/tmp/mysql-oopsblog.sock
    * :/tmp/mysql-oopsblog.sock

    None of them work. Any ideas?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Forget it. I found it. Details in the next reply.

    The main reason this didn’t work was the combination of PHP version and MySQL version. The MySQL version is 4.1.7, and PHP’s is 4.3.2. This PHP version uses the old password hashing format, so I had to do a mysqladmin ... old-password mypasswd.

    After changing this, a DB_HOST setting of ‘localhost:/tmp/mysql-oopsblog.sock’ works. But in order to specify the port, one needs to enter ‘’. If one uses ‘localhost’, PHP for some reason tries to connect to the wrong socket.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘mysqladmin ping works, but WP can’t connect’ is closed to new replies.